uva 11374 - Airport Express(Dijkstra预处理+枚举)

Problem D: Airport Express

In a small city called Iokh, a train service, Airport-Express, takes residents to the airport more quickly than other transports. There are two types of trains in Airport-Express, the Economy-Xpress and the Commercial-Xpress. They travel at different speeds, take different routes and have different costs.

Jason is going to the airport to meet his friend. He wants to take the Commercial-Xpress which is supposed to be faster, but he doesn't have enough money. Luckily he has a ticket for the Commercial-Xpress which can take him one station forward. If he used the ticket wisely, he might end up saving a lot of time. However, choosing the best time to use the ticket is not easy for him.

Jason now seeks your help. The routes of the two types of trains are given. Please write a program to find the best route to the destination. The program should also tell when the ticket should be used.

Input

The input consists of several test cases. Consecutive cases are separated by a blank line.

The first line of each case contains 3 integers, namely N, S and E (2 ≤ N ≤ 500, 1 ≤ S, EN), which represent the number of stations, the starting point and where the airport is located respectively.

There is an integer M (1 ≤ M ≤ 1000) representing the number of connections between the stations of the Economy-Xpress. The next M lines give the information of the routes of the Economy-Xpress. Each consists of three integers X, Y and Z (X, YN, 1 ≤ Z ≤ 100). This means X and Y are connected and it takes Z minutes to travel between these two stations.

The next line is another integer K (1 ≤ K ≤ 1000) representing the number of connections between the stations of the Commercial-Xpress. The next K lines contain the information of the Commercial-Xpress in the same format as that of the Economy-Xpress.

All connections are bi-directional. You may assume that there is exactly one optimal route to the airport. There might be cases where you MUST use your ticket in order to reach the airport.

Output

For each case, you should first list the number of stations which Jason would visit in order. On the next line, output "Ticket Not Used" if you decided NOT to use the ticket; otherwise, state the station where Jason should get on the train of Commercial-Xpress. Finally, print the total time for the journey on the last line. Consecutive sets of output must be separated by a blank line.

Sample Input

4 1 4
4
1 2 2
1 3 3
2 4 4
3 4 5
1
2 4 3

Sample Output

1 2 4
2
5


Problemsetter: Raymond Chun
Originally appeared in CXPC, Feb. 2004

套模板时一定要注意模版中编号是从0开始的,若与题目中编号不一致,一定要记得在输入时“减1”,在输出时再“加1”;

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;

const int INF = 1000000000;
const int maxn =  500 + 5;
struct Edge{
    int from,to,dist;
};

struct HeapNode{
    int d,u;
    bool operator < (const HeapNode& rhs) const{
        return d > rhs.d;
    }
};

struct Dijkstra{
    int n,m;
    vector<Edge> edges;
    vector<int> G[maxn];
    bool done[maxn];
    int d[maxn];
    int p[maxn];

    void init(int n){
        this -> n = n;
        for(int i = 0;i < n;i++)    G[i].clear();
        edges.clear();
    }

    void AddEdges(int from,int to,int dist){
        edges.push_back((Edge){from,to,dist});
        m = edges.size();
        G[from].push_back((m-1));
    }

    void dijkstra(int s){
        priority_queue<HeapNode> Q;
        for(int i = 0;i < n;i++)    d[i] = INF;
        d[s] = 0;
        memset(done,0,sizeof(done));
        Q.push((HeapNode){0,s});
        while(!Q.empty()){
            HeapNode x = Q.top();Q.pop();
            int u = x.u;
            if(done[u]) continue;
            done[u] = true;
            for(int i = 0;i < G[u].size();i++){
                Edge& e = edges[G[u][i]];
                if(d[e.to] > d[u] + e.dist){
                    d[e.to] = d[u] + e.dist;
                    p[e.to] = e.from;
                    Q.push((HeapNode){d[e.to],e.to});
                }
            }
        }
    }

    void getpath(int s,int e,vector<int>& path){
        int pos = e;
        while(1){
            path.push_back(pos);
            if(pos == s)
                break;
            pos = p[pos];
        }
    }
};

int N,S,E;
vector<int> path;
Dijkstra solver[2];


int main(){
    int time,ansp,ansq,kase = 0;
    while(scanf("%d%d%d",&N,&S,&E) != EOF){
        S--;E--;
        if(kase != 0)   printf("\n");
        kase++;
        solver[0].init(N);solver[1].init(N);
        path.clear();
        int M,K,X,Y,Z;
        scanf("%d",&M);
        while(M--){
            scanf("%d%d%d",&X,&Y,&Z);X--;Y--;
            solver[0].AddEdges(X,Y,Z);solver[1].AddEdges(X,Y,Z);
            solver[0].AddEdges(Y,X,Z);solver[1].AddEdges(Y,X,Z);
        }
        solver[0].dijkstra(S);
        solver[1].dijkstra(E);
        ansp = -1;
        time = solver[0].d[E];
        scanf("%d",&K);
        while(K--){
            scanf("%d%d%d",&X,&Y,&Z);X--;Y--;
            if(Z+solver[0].d[X]+solver[1].d[Y] < time){
                time = Z+solver[0].d[X]+solver[1].d[Y];
                ansp = X;ansq = Y;
            }
            if(Z+solver[0].d[Y]+solver[1].d[X] < time){
                time = Z+solver[0].d[Y]+solver[1].d[X];
                ansp = Y;ansq = X;
            }
        }
        if(ansp == -1){
            solver[0].getpath(S,E,path);
            reverse(path.begin(),path.end());
            for(int i = 0;i < path.size()-1;i++)
                printf("%d ",path[i]+1);
            printf("%d\n",E+1);
            printf("Ticket Not Used\n");
            printf("%d\n",time);
        }
        else{
            solver[0].getpath(S,ansp,path);
            reverse(path.begin(),path.end());
            solver[1].getpath(E,ansq,path);
            for(int i = 0;i < path.size()-1;i++)
                printf("%d ",path[i]+1);
            printf("%d\n",E+1);
            printf("%d\n",ansp+1);
            printf("%d\n",time);
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值