FZU 2215 Simple Polynomial Problem 多项式模拟 表达式树

Problem 2215 Simple Polynomial Problem

Time Limit: 1000 mSec    Memory Limit : 32768 KB


Problem Description

You are given an polynomial of x consisting of only addition marks, multiplication marks, brackets, single digit numbers, and of course the letter x. For example, a valid polynomial would be: (1+x)*(1+x*x+x+5)+1*x*x.

You are required to write the polynomial into it's minimal form by combining the equal terms.

For example, (1+x)*(1+x) would be written as x^2+2*x+1.

Also, (1+x)*(1+x*x+x+5)+1*x*x would be written as x^3+3*x^2+7*x+6.


Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there will be one polynomial which it's length would be not larger than 1000.

It is guaranteed that every input polynomial is valid, and every number would be a single digit.


Output

For each polynomial, output it's minimal form. If the polynomial's minimal form has n terms, output n space-separated integers.

You only have to output each term's corresponding constant (from highest to lowest). In case the constant gets too big, output the remainder of dividing the answer by 1000000007 (1e9 + 7).


Sample Input
4
1*(1+1*(1+1))
(1+x)*(1+x)
x*((1+x)*(1+x*x+x+5)+1*x*x)

(x*x*x*0+x*2)*x


Sample Output
3
1 2 1
1 3 7 6 0

2 0 0

    题意很好理解,给出一个式子,将这个式子进行化简,然后输出这个多项式的系数。记得貌似以前做过一个类似的题,用栈进行模拟,不过印象中那个题要比这个题更简单一些,数据也更小一些。比赛的时候没再敲这个题,耐不下心(不过感觉耐下心敲也不一定能敲对→_→)。

    比完赛才补了这个题,不过还是参考了网上的博客敲的,自己没耐心去码.....既然参考了网上的,也没再用栈的方式,找到有人用表达式树的方式来做这道题,就是将整个多项式构建成一个树再进行运算,干脆学习了一下。

    下面是AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int mod=1000000007;
const int MAXN=2005;
//#pragma comment(linker,"/STACK:1024000000,1024000000")

int max(int x,int y)
{
    return x>y?x:y;
}

struct Node
{
    int len,s[MAXN];
    int &operator[](int i)
    {
        return s[i];
    }
    const int &operator[](int i)const
    {
        return s[i];
    }
    Node operator+ (const Node &P)const
    {
        int i;
        Node ret;
        memset(ret.s,0,sizeof(ret.s));
        ret.len=max(len,P.len);
        for(i=0;i<=ret.len;i++)
            ret[i]=((long long)s[i]+P[i])%mod;
        return ret;
    }
    Node operator* (const Node &P)const
    {
        int i,j;
        Node ret;
        memset(ret.s,0,sizeof(ret.s));
        ret.len=len+P.len;
        for(i=0;i<=len;i++)
            for(j=0;j<=P.len;j++)
                ret[i+j]=(ret[i+j]+(long long)s[i]*P[j])%mod;
        while(ret.len&&!ret[ret.len])
            ret.len--;
        return ret;
    }
    void print()
    {
        int i;
        for(i=len;i>0;i--)
            cout<<s[i]<<" ";
        cout<<s[0]<<endl;
    }
};

Node a[MAXN];
char op[MAXN];
int lch[MAXN],rch[MAXN],sz;

int build(char *S,int L,int R)
{
    int c[]={-1,-1},p=0,u;
    int i;
    if(L==R)
    {
        sz++;
        u=sz;
        op[u]='.';
        memset(a[u].s,0,sizeof(a[u].s));
        if(S[L]=='x')
        {
            a[u].len=1;
            a[u][1]=1;
        }
        else
        {
            a[u].len=0;
            a[u][0]=S[L]-'0';
        }
        return u;
    }

    for(i=L;i<=R;i++)
    {
        switch(S[i])
        {
            case '(':p++;break;
            case ')':p--;break;
            case '+':
                if(!p)
                    c[0]=i;
                break;
            case '*':
                if(!p)
                    c[1]=i;
                break;
        }
    }

    if(c[0]<0)
        c[0]=c[1];
    if(c[0]<0)
        u=build(S,L+1,R-1);
    else
    {
        sz++;
        u=sz;
        op[u]=S[c[0]];
        lch[u]=build(S,L,c[0]-1);
        rch[u]=build(S,c[0]+1,R);
    }
    return u;
}

Node solve(int u)
{
    if(op[u]=='.')
        return a[u];
    Node al=solve(lch[u]),ar=solve(rch[u]);
    switch(op[u])
    {
        case '+':return al+ar;
        case '*':return al*ar;
    }
}

char str[MAXN];

int main()
{
    int Size = 10240000;
    char *p = (char *)malloc(Size) + Size;
    __asm__("movl %0, %%esp\n" :: "r"(p));
    int T;
    scanf("%d",&T);
    while(T--)
    {
        sz=0;
        scanf("%s",str);
        int n=strlen(str);
        int rt=build(str,0,n-1);
        Node ret=solve(rt);
        ret.print();
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
为了方便,把代码放在Word里面了,每次上机实验的题目代码都在。 第一次: 对如下多项式编写类定义: + + +…+ 其中,n为多项式的次数。完成如下功能: (1) 可存储任意大的多项式(提示:可用动态数组实现)。 (2) 定义构造函数、析构函数、拷贝构造函数。 (3) 包含一个static成员存储定义的多项式的数量。 (4) 定义一个成员函数输出多项式。(可参照-x^4-6x^3+5格式输出) (5) 定义一个成员函数计算多项式的值。 (6) 写main函数测试类的功能。 (7) 采用多文件实现。 考虑:哪些成员函数可以声明为const. 第二次: (8) 重载“+”运算符,实现两个多项式相加。 (9) 重载“-”运算符,实现两个多项式相减。 (10) 重载“*”运算符,实现两个多项式相乘。 (11) 重载“=”运算符,实现两个多项式的赋值运算。 考虑:把其中某个运算符重载为友元函数。 第三次: C++的一般编译器都定义和封装了字符串功能,请模仿定义string类的实现,可以实现并支持如下功能: (1)string s = “吉林大学”; (2)string t = s; (3)string m; m = t; (4)m.legnth() 函数测量字符串的长度 (5)m.cat(string const &)连接字符串 第四次: 我公司为仪器生产企业,目前生产摄像机和行车记录仪两种产品,分别销售给用户。 摄像机包含摄像、图像质量设定、编码算法等属性。 将摄像机增加相应芯片(具有操作菜单、自动拍摄、车速传感器、源代码等功能)后,形成一个行车记录仪。 要求: 设计摄像机类,并请根据下列不同的功能要求,采用不同的继承方式,设计行车记录仪类,并添加测试代码,体验不同继承方式下的成员访问属性。(类设计时可根据需要自行添加数据成员和其他成员函数。) (1) 行车记录仪的芯片可以使用摄像机的摄像、图像质量设定功能。 行车记录仪用户可以操作行车记录仪的操作菜单和摄像机的摄像功能。 (2)行车记录仪的芯片可以使用摄像机的拍摄、图像质量设定功能。 行车记录仪用户仅仅可以操作行车记录仪的操作菜单。 (3) 行车记录仪的芯片可以使用摄像机的拍摄、图像质量设定功能。 行车记录仪用户仅仅可以操作行车记录仪的操作菜单 同时其他公司购买行车记录仪,因该公司也用于销售,不得泄露其全部内容 课后: (1)采用组合方式设计行车记录仪类,增加相应测试代码,体验继承和组合的关系。 (2)分别为继承和组合方式下为各类添加构造函数、析构函数,增加相应测试代码,体验对象的初始化和构造顺序。 (3)将摄像机类和行车记录仪类功能相近的函数(如拍摄、编码等功能函数)设为同名函数,增加相应测试代码,体验同名函数覆盖。 (4)为我公司建立一个多态的产品类层次结构,使用抽象类,测试时,创建一个基类指针的容器,通过基类指针调用虚函数,体验多态。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值