SDNU 1370.Freckles 最小生成树 kruskal算法


1370.Freckles
Time Limit: 1000 MS    Memory Limit: 131072 KB

Description


In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through.

Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.


Input

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.


Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.


Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41


    后来发现SDNU后面有道拷过来的题正好是当时出的1229,不过范围没有改,还是100,用这道题试了一下,kruskal可以过。所以这题用kruskal再贴一个代码,以示边少的情况才能用kruskal。

    下面AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef struct node
{
    double x,y;
}Point;
Point p[1005];
double Distance(Point a,Point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

struct edge
{
    int fr,to,nxt;
    double w;
};

int cmp(edge a,edge b)
{
    return a.w<b.w;
}

int pre[1005],n,head[1005],cnt;

edge e[1000005];

void add(int fr,int to,double w)
{
    e[cnt].fr=fr;
    e[cnt].to=to;
    e[cnt].w=w;
    e[cnt].nxt=head[fr];
    head[fr]=cnt++;
}

int fin(int x)
{
    if(x==pre[x])
        return x;
    return pre[x]=fin(pre[x]);
}

double Kruskal()
{
    for(int i=1;i<=n;++i)
    {
        pre[i]=i;
    }
    sort(e,e+cnt,cmp);
    double ans=0;
    for(int i=0;i<cnt;++i)
    {
        int u=fin(e[i].fr);
        int v=fin(e[i].to);
        if(u!=v)
        {
            ans+=e[i].w;
            pre[u]=v;
        }
    }
    return ans;
}

int main()
{
    int i,j;
    while(scanf("%d",&n)!=EOF)
    {
        cnt=0;
        memset(e,0,sizeof(e));
        memset(pre,0,sizeof(pre));
        memset(p,0,sizeof(p));
        memset(head,-1,sizeof(head));
        for(i=1;i<=n;i++)
        {
            scanf("%lf%lf",&p[i].x,&p[i].y);
        }
        for(i=1;i<=n;i++)
        {
            for(j=i+1;j<=n;j++)
            {
                double t=Distance(p[i],p[j]);
                add(i,j,t);
                add(j,i,t);
            }
        }
        printf("%.2f\n",Kruskal());
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值