M

Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.


Input

The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.


Output

The output will consist of one line per input list, containing a count of the items that are double some other item.


Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1


Sample Output

3
2
0

题意:

在每行数中寻找二倍关系的数,看看有几对

分析:

可以用排列,然后用两个数做比较成立则加1,如果大的数比小的数小,则大数往后推直到大于或等于小数的2倍   然后再往后推小数 大数后面没有数了就停止

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,j=0,a[100],k,l,s;
    while(cin>>a[j]&&a[j]!=-1)
    {
        while(cin>>a[++j]&&a[j]!=0){}
        sort(a,a+j);
        for(s=0,l=0,k=1;k<j;l++)
        {
            if(a[k]==a[l]*2) s++;
            else
            if(a[k]<2*a[l])
            {
                while(a[k]<=a[l]*2)
                {
                    k++;
                    if(a[k]==a[l]*2)
                        s++;
                    if(k==j)break;
                }
            }
        }
    j=0;
    cout<<s<<endl;
    }
}


感受:

主要是在判断大数停止后推的时候有点麻烦 多用了点时间    其他都挺简单 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值