O

Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.


Input



Input contains multiple test cases. Each test case starts with a number N (0 < N < 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.


Output



For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


Sample Input



5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output



red
pink

题意:

就是看看出现的单词次数多的  并输出

分析:

可以用multiset 然后利用 erase返回个数 进行比较

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,i,l,k;
    string h,p,t;
    multiset<string>v;
    while(cin>>n&&n)
    {
        for(i=0,l=0;i<n;i++)
        {
            cin>>h;
            v.insert(h);
        }
        while(v.empty()!=1)
        {
            t=*(v.begin());
            k=v.erase(t);
            if(k>l){
                l=k;
                p=t;
            }
        }
        cout<<p<<endl;
    }
}

感受:

这个题没有坑 完全靠基础奋斗

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值