S

Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

题意:

就是PUT代表输入队列,get代表输出队列,如果队列是空的就输出EMPTY   QUEUE!否则输出内容,put后跟着三个信息,第三个是优先级,优先级大的反而小,优先级相同,输出先出现的

分析:

用优先队列就行

代码:

#include<bits/stdc++.h>
using namespace std;
struct can
{
    string a,b;
    long int c;
    bool operator<(const can h)const
    {
        return c>h.c;
    }
};
int main()
{
    string s;
    priority_queue<can>v;
    can f;
    while(cin>>s)
    {
        if(s=="GET"&&v.size()==0)
            cout<<"EMPTY QUEUE!"<<endl;
        else
            if(s=="GET")
        {
            cout<<v.top().a<<" "<<v.top().b<<endl;
            v.pop();
        }
        else
        {
            cin>>f.a>>f.b>>f.c;
            v.push(f);
        }
    }
}
感受:

我感觉这是有史以来叫我最憋屈的题发火我按照题目要求控制输入的个数竟然不能通过,我交了6遍没有过,然后把控制输入量的删了就过了。。。真是气死我了发火

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值