28:Maximum sum

描述
Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
                     t1     t2 
         d(A) = max{ ∑ai + ∑aj | 1 <= s1 <= t1 < s2 <= t2 <= n }
                    i=s1   j=s2

Your task is to calculate d(A).
输入
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
输出
Print exactly one line for each test case. The line should contain the integer d(A).
样例输入
1

10
1 -1 2 2 3 -3 4 -4 5 -5
样例输出
13
提示
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended. 题意:

就是找到两个字段和,找出最大的和,输出,中间不能有重叠

分析:

就是从左到右找每个i处的最大子段和,在从右到左,最后统计和的最大值

代码:

#include<bits/stdc++.h>
using namespace std;
long long int f[50005],h[50005],maxn,temp,p;
int main()
{
    int a[50005],n,i,t,k;
    while(cin>>t)
    {
        for(k=0;k<t;k++){
        cin>>n;
        for(i=1;i<=n;i++)
            cin>>a[i];
        memset(f,0,sizeof(f));
        memset(h,0,sizeof(h));
        for(i=1,temp=0,h[0]=-10005;i<=n;i++)
        {
            if(temp<0)
                temp=0;
            temp+=a[i];
            if(temp>h[i-1])
                h[i]=temp;
            else
            h[i]=h[i-1];
        }
        for(i=n,temp=0,f[n+1]=-10005;i>0;i--)
        {
            if(temp<0)
                temp=0;
            temp+=a[i];
            if(temp>f[i+1])
                f[i]=temp;
            else
            f[i]=f[i+1];
        }
        for(i=1,maxn=-100000;i<n;i++)
        {
            p=f[i+1]+h[i];
            if(p>maxn)
                maxn=p;
        }
        cout<<maxn<<endl;
        }
    }
}
感受:

一开始老是出不来,因为我没有处理好重叠部分的问题,最后想到了算f[i]+h[i-1],不过想出来就感觉自己棒棒哒偷笑

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值