uva 270 Lining Up


 Lining Up 

``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3

</pre><pre class="cpp" name="code">题意:找出在同一直线上的点的个数最多的个数
以一点为原点求出与其他点的斜率,排序查找相等的斜率最多的个数,再以下一个点为原点,按之前的方法查找最值更新最大值(做过原点的点不许再求到他的斜率之前求过再求就会重复)


</pre><pre class="cpp" name="code">#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define INF 0x7FFFFFFF
using namespace std;
double ans[100000];
int a[1000],b[1000];
char s[1000];
int t,l,i,j,con,k,sum,MAX,n;
int tj(int n)
{
	int MAX = 0, sum = 1;

	int i;
	for (i = 1; i < n; i++)
	{
		if (ans[i-1] == ans[i])
		{
			sum++;
		}
		else
		{
			if (sum > MAX)
			{
				MAX = sum;
			}
			sum = 1;
		}
	}
	if (sum > MAX)
	{
		MAX =sum;
	}
	return MAX+1;
}

int M(int n)
{
	int np= 0;
	int i, j, k;
	for (i = 0; i < n; i++)
	{
		for (j = i + 1, k = 0; j < n; j++, k++)
		{
			if (a[j] == b[i])
			{
				ans[k] = INF;
			}
			else
			{
				ans[k] = (double)(b[j] - b[i]) / (double)(a[j] - a[i]);
			}
		}

		sort(ans, ans+k);

		int w = tj(k);
		if (w > np)
		{
			np = w;
		}
	}
	return np;
}

int main()
{
    scanf("%d\n", &t);
    while (t-- != 0)
    {
        int i;
        for (i = 0; gets(s) != NULL && s[0] != '\0'; i++)
        {
            sscanf(s, "%d%d", &a[i], &b[i]);
        }
        n=i;
        printf("%d\n", M(n));
        if (t!= 0)
        {
            putchar('\n');
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值