HDU 1024 Let theBalloon Rise

Let theBalloon Rise

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 118091    Accepted Submission(s):46312


Problem Description

Contest timeagain! How excited it is to see balloons floating around. But to tell you asecret, the judges' favorite time is guessing the most popular problem. Whenthe contest is over, they will count the balloons of each color and find theresult.

This year, they decide to leave this lovely job to you. 

 

 

Input

Input containsmultiple test cases. Each test case starts with a number N (0 < N <=1000) -- the total number of balloons distributed. The next N lines contain onecolor each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to beprocessed.

 

 

Output

For each case,print the color of balloon for the most popular problem on a single line. It isguaranteed that there is a unique solution for each test case.

 

 

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

 

 

Sample Output

red

pink

 

 

Author

WU, Jiazhi

 

 

Source

ZJCPC2004

 

这里用map容器解题,代码如下

#include <iostream>
#include <map>

using namespace std;

int main()
{
    string str;
    int n;
    while (cin >> n)
    {
        if (n == 0)
            break;

        map<string, int>s;
        map<string, int>::iterator iter;

        for (int i=0; i<n; i++)
        {
            cin >> str;
            s[str]++;
        }

        int nmax = 0;
        string ans;
        for (iter=s.begin(); iter!=s.end(); iter++)
        {
            if (nmax < iter->second)
            {
                nmax = iter->second;
                ans = iter->first;
            }
        }

        cout << ans << endl;
    }
	return 0;
}


关于map容器,C++中map容器提供一个键值对容器,在头文件 <map> 中。


1、定义:

map<string, int> myMap;


2、插入数据 

myMap["a"] = 1; 					//1
myMap.insert(map<string, int>::value_type("b",2)); 	//2
myMap.insert(pair<string,int>("c", 3)); 		//3
myMap.insert(make_pair<string,int>("d", 4));  		//4


3、查找和修改数据

int i = myMap["a"]; 
myMap["a"] = i;

map<string, int>::iterator iter; 
iter.find("b"); 
int i = iter->second; 
iter->second = i;


4、删除数据

myMap.erase(iter); 	//1
myMap.erase("c");	//2

5、迭代数据
for (iter = myMap.begin(); iter != myMap.end(); iter++) {}

6、其它常用方法

myMap.size()		//返回元素数目 
myMap.empty()		//判断是否为空 
myMap.clear()		//清空所有元素 

以上为map的常用方法,在信息学竞赛中较为常用。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值