HDOJ 1004 Letthe Balloon Rise (寻找最多的颜色)

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 106509    Accepted Submission(s): 41255


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
 

Author
WU, Jiazhi
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1005  1019  1013  1012  1020 

 

题意:

找出颜色最多的气球。


代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define MYDD 1103

using namespace std;

struct Q {
	char color[16];
} balloons[MYDD];

bool cmp_color(Q x,Q y) {//对气球颜色进行降序排序...升序貌似答案是错的 
	return strcmp(x.color,y.color)>0? 1:0;
}

int MAX(int x,int y) {
	return x<y? x:y;//
}

int main() {
	int n;
	char dd[16];//答案颜色
	while(scanf("%d",&n)&&n) {
		for(int j=0; j<n; j++)
			scanf("%s",balloons[j].color);

		sort(balloons,balloons+n,cmp_color);

		char now[16];//记录当前待比较的颜色
		int max=0;//记录最多气球颜色的个数
		int ans=0;//记录当前气球颜色的个数
		strcpy(now,balloons[0].color);
		strcpy(dd,balloons[0].color);
		for(int j=0; j<n; j++) {
			if(strcmp(now,balloons[j].color)==0)
				ans++;
			else {//颜色不同
				if(ans>max) {
					strcpy(dd,balloons[j-1].color);//ans 记录的是前一个气球颜色的个数
					max=ans;
				}
				strcpy(now,balloons[j].color);//记为当前气球颜色
				ans=1;
			}
		}
		puts(dd);
	}
	return 0;
}
/*
7
C A B A B C C
3
a B C
*/



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值