POJ - 2406 Power Strings —— next数组求循环节

8 篇文章 0 订阅

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 54168 Accepted: 22583

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题意:给定字符串,求(最小)循环节最多循环了多少次

思路:next数组求出循环节

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <cstring>
#include <queue>
#include <algorithm>
#define ll long long
#define max_ 1010000
#define les 1e-6
#define inf 0x3f3f3f3f
using namespace std;
int f[max_];
char s[max_];
int main(int argc, char const *argv[]) {
    while(scanf(" %s",s))
    {
        if(s[0]=='.')
        break;
        f[0]=-1;
        int l=strlen(s);
        for(int i=1;i<l;i++)
        {
            int j=f[i-1];
            while((j>=0)&&(s[i]!=s[j+1]))
            j=f[j];
            if(s[i]==s[j+1])
            f[i]=j+1;
            else
            f[i]=-1;
        }
        int d=l-(f[l-1]+1);
        if(l%d==0)
        printf("%d\n",l/d);
        else
        printf("1\n" );
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值