HDU - 3294 Girls' research

Girls' research

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3523    Accepted Submission(s): 1344


Problem Description
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
 

Input
Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.
 

Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.
 

Sample Input
 
 
b babd a abcd
 

Sample Output
 
 
0 2 aza No solution!

题意:给定一个key字母和字符串,后面字符串中的key实际上都对应为a字母,key+1对应b,以此类推

思路:裸manecher跑一遍,输出时按照密文转化关系输出

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <cstring>
#include <queue>
#include <algorithm>
#define ll long long
#define max_ 201000
#define inf 0x3f3f3f3f
#define mod 1000000007
using namespace std;
int n;
char ss[max_],s[max_*2],c;
int p[max_*2];
int main(int argc, char const *argv[]) {
    while(scanf(" %c",&c)!=EOF)
    {
        scanf(" %s",ss);
        s[0]='$';
        s[1]='#';
        int l=strlen(ss);
        for(int i=0;i<l;i++)
        {
            s[i+i+2]=ss[i];
            s[i+i+3]='#';
        }
        s[l+l+2]='\0';
        l=strlen(s);
        int mx=0,id=0;
        for(int i=1;i<=l;i++)
        {
            if(i<mx)
            p[i]=min(p[2*id-i],mx-i);
            else
            p[i]=1;
            while(s[i+p[i]]==s[i-p[i]])
            p[i]++;
            if(i+p[i]>mx)
            {
                id=i;
                mx=i+p[i];
            }
        }
        int maxx=-1,k;
        for(int i=1;i<l;i++)
        {
            if(p[i]>maxx)
            {
                maxx=p[i];
                k=i;
            }
        }
        if(maxx==2)
        printf("No solution!\n" );
        else
        {
            printf("%d %d\n",(k-maxx)/2,(k+maxx-4)/2);
            for(int i=(k-maxx)/2;i<=(k+maxx-4)/2;i++)
            printf("%c",ss[i]-c+'a'>='a'?ss[i]-c+'a':'z'+ss[i]-c+1 );
            printf("\n" );
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值