HDU 3294 Girls' research

Girls' research

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3506    Accepted Submission(s): 1336


Problem Description
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
 

Input
Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.
 

Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.
 

Sample Input
  
  
b babd a abcd
 

Sample Output
  
  
0 2 aza No solution!
 

Author
wangjing1111
 

Source
 

题目大意:给你一个字母和一个字符串,这个字母就代替了字符串中的a,然后以此类推得出一个新的字符串,在求出这个新字符串中最长回文串的起始位置和终止位置,并将这个回文字符串输出

用manacher算法过一遍,然后求出最大的p[i]和它在新字符串中的下标index,那么这个回文串的起始位置就是(index-p[i])/2,终止位置就是(index+p[i])/2-2

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=2e6+10;
char str[maxn];
char str_new[maxn<<1];
int p[maxn<<1];
int init(){
	int len=strlen(str);
	str_new[0]='$';
	str_new[1]='#';
	int j=2;
	for(int i=0;i<len;i++){
		str_new[j++]=str[i];
		str_new[j++]='#';
	}
	str_new[j]='#';
	return j;
}
int Manacher(){
	int len=init();
	int id;
	int maxx=0;
	for(int i=1;i<len;i++){
		if(i<maxx) p[i]=min(p[2*id-i],maxx-i);
		else p[i]=1;
		while(str_new[i-p[i]]==str_new[i+p[i]]) p[i]++;
		if(maxx<i+p[i]){
			maxx=i+p[i];
			id=i;
		}
	}
	return len;
}
int main(){
	ios::sync_with_stdio(false);
	char ch;
	while(cin>>ch){
		cin>>str;
		int len=strlen(str);
		for(int i=0;i<len;i++){
			str[i]-=(ch-'a');
			if(str[i]<'a') str[i]+=26;
		}
		len=Manacher();
		int ans=0;
		int x,y;
		for(int i=1;i<len;i++){
			if(p[i]>ans){
				ans=p[i];
				x=i;
			}
		}
		if(ans==2) cout<<"No solution!"<<endl;
		else{
			int left=(x-ans)/2;
			int right=(x+ans)/2-2;
			cout<<left<<' '<<right<<endl;
			for(int i=left;i<=right;i++){
				cout<<str[i];
			}
			cout<<endl;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值