A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<iostream>
#include<string> 
#define MAX 1000
using namespace std; 

string Add(string a,string b)
{
	int i,j,cf=0;
	string c="";
	char t;  
	i=a.size()-1; j=b.size()-1; 
	while (i>=0&&j>=0)
	{
		t=a[i--]+b[j--]-'0'+cf; 
		if (t>'9')
		{
			t-=10; 
			cf=1; 
		}else cf=0;  
		c+=t;  
	}
	if (i>=0)
	{
		while(i>=0&&cf){ 
			t=a[i--]+1;  
			if(t>'9'){
				t-=10; 
				cf=1; 
			}else cf=0; 
			c+=t; 
		}  
		while(i>=0) 
			c+=a[i--]; 
	}
	else if (j>=0)
	{
		while(j>=0&&cf){ 
			t=b[j--]+1;  
			if(t>'9'){
				t-=10; 
				cf=1; 
			}else cf=0; 
			c+=t; 
		}  
		while(j>=0) 
			c+=b[j--]; 
	}
	if(cf)c+='1'; 
	int s=c.size()-1;
	for (int i=0,j=s;i<j;i++,j--)
	{ 
		t=c[i]; c[i]=c[j];c[j]=t; 
	}
	return c;
}

int main()
{
	int t,k=1;
	string a,b;
	cin>>t;
	while(t--)
	{
		cin>>a>>b;
		cout<<"Case "<<k++<<":"<<endl;
		cout<<a<<" + "<<b<<" = "<<Add(a,b)<<endl;
		if(t)cout<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值