Squares(存在多少正方形,暴力枚举 )

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 17128 Accepted: 6513

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

code1:

枚举两点,以其形成的线段为正方形的一边,求出另外两点的坐标,二分查找该两点是否存在

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
struct node
{
    int x,y;
    bool operator<(const node &nodee)const
    {
        if(x==nodee.x) return y<nodee.y;
        return x<nodee.x;
    }
} p[1001];
int main()
{
    int n,i,j,ans;
    while(scanf("%d",&n),n)
    {
        for(i=1; i<=n; i++)
            scanf("%d%d",&p[i].x,&p[i].y);
        sort(p+1,p+n+1);
        ans=0;
        for(i=1; i<=n; i++)//枚举两点,以其形成的线段为正方形的一边,求出另外两点的坐标,二分查找该两点是否存在
            for(j=i+1; j<=n; j++)
            {
                node tem;//表示另外两点的坐标
                tem.x=p[i].x-p[j].y+p[i].y;//
                tem.y=p[i].y+p[j].x-p[i].x;
                if(!binary_search(p+1,p+1+n,tem))
                    continue;
                tem.x=p[j].x-p[j].y+p[i].y;
                tem.y=p[j].y+p[j].x-p[i].x;
                if(!binary_search(p+1,p+1+n,tem))
                continue;
                ans++;
            }
        printf("%d\n",ans/2);//重复
    }
    return 0;
}


code2:

枚举一条对角线上的两点 求出另一条对角线上的点,二分查找是否存在该两点,

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include<math.h>
using namespace std ;
#define esp 1e-9
struct node{
    double x , y ;
}p[1100] ;
int n;
bool cmp(node a,node b)
{
    return ( a.x < b.x || ( a.x == b.x && a.y < b.y ) ) ;
}
bool judge(double x,double y)
{
    int low = 1 , mid , high = n;
    while( low <= high )//边界控制是个大问题!!!
    {
        mid = (low + high) / 2 ;
        if( fabs(p[mid].x-x) < esp && fabs(p[mid].y-y) < esp )
            return true ;
        else if( p[mid].x-x > esp || ( fabs(p[mid].x-x) < esp && p[mid].y-y > esp ) )
            high = mid-1 ;
        else
            low = mid +1 ;
    }
    return false ;
}
int main()
{
    int  i,j,num ;
    while( scanf("%d", &n) && n )
    {
        num=0 ;
        for(i = 1 ; i <= n ; i++)
            scanf("%lf %lf", &p[i].x, &p[i].y) ;
        sort(p+1,p+n+1,cmp) ;
        for(i = 1 ; i <= n ; i++)
            for(j = i+1 ; j <= n ; j++)
            {
                double x=(p[i].x+p[j].x)/2 ;
                double y = (p[i].y+p[j].y)/2 ;
                double xx = p[i].x - x ;
                double yy = p[i].y - y ;
                if( judge(x+yy,y-xx) && judge(x-yy,y+xx) )
                    num++ ;
            }
        printf("%d\n", num/2) ;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: `squares.append()`是Python语言中列表对象的一个方法,用于在列表末尾添加一个元素。例如,如果你有一个名为"squares"的列表,并且想在其末尾添加数字9,你可以使用以下代码: ``` squares.append(9) ``` 这将在列表末尾添加数字9。 ### 回答2: 在Python中,squares.append()是一个列表方法,用于向列表中添加元素。该方法接受一个参数,即要添加的元素,并将该元素添加到列表的末尾。 例如,假设我们有一个空列表squares。我们可以使用以下代码将一个元素添加到列表中: squares = [] squares.append(4) 现在,squares列表将包含一个元素,即数字4。我们可以进一步使用append()方法来添加更多的元素到列表中。例如: squares.append(9) squares.append(16) squares.append(25) 现在,squares列表将依次包含数字4、9、16和25。 总结而言,squares.append()是一个有用的列表方法,它允许我们在Python中向列表中添加元素。无论列表是否为空,我们都可以使用append()方法将元素添加到列表的末尾。 ### 回答3: `python squares.append`是Python语言中的一个方法,用于将一个元素追加到列表(list)中。在使用该方法时,需要先创建一个列表对象,并且可以在括号内指定要追加的元素。 例如,以下是一个使用`squares.append`的示例: ```python squares = [] # 创建一个空的列表对象 # 使用append方法将元素依次追加到列表中 squares.append(1) squares.append(4) squares.append(9) squares.append(16) print(squares) # 输出结果为:[1, 4, 9, 16] ``` 在上述示例中,我们首先创建了一个空的列表对象`squares`。然后,使用`squares.append`方法依次向列表中追加了四个元素,分别是1、4、9和16。最后,通过`print(squares)`将列表内容打印输出,结果为`[1, 4, 9, 16]`。 总而言之,`python squares.append`是用于将一个元素追加到列表中的Python方法,可以方便地扩充列表的内容。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值