Squares(存在多少正方形,暴力枚举 )

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 17128 Accepted: 6513

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

code1:

枚举两点,以其形成的线段为正方形的一边,求出另外两点的坐标,二分查找该两点是否存在

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
struct node
{
    int x,y;
    bool operator<(const node &nodee)const
    {
        if(x==nodee.x) return y<nodee.y;
        return x<nodee.x;
    }
} p[1001];
int main()
{
    int n,i,j,ans;
    while(scanf("%d",&n),n)
    {
        for(i=1; i<=n; i++)
            scanf("%d%d",&p[i].x,&p[i].y);
        sort(p+1,p+n+1);
        ans=0;
        for(i=1; i<=n; i++)//枚举两点,以其形成的线段为正方形的一边,求出另外两点的坐标,二分查找该两点是否存在
            for(j=i+1; j<=n; j++)
            {
                node tem;//表示另外两点的坐标
                tem.x=p[i].x-p[j].y+p[i].y;//
                tem.y=p[i].y+p[j].x-p[i].x;
                if(!binary_search(p+1,p+1+n,tem))
                    continue;
                tem.x=p[j].x-p[j].y+p[i].y;
                tem.y=p[j].y+p[j].x-p[i].x;
                if(!binary_search(p+1,p+1+n,tem))
                continue;
                ans++;
            }
        printf("%d\n",ans/2);//重复
    }
    return 0;
}


code2:

枚举一条对角线上的两点 求出另一条对角线上的点,二分查找是否存在该两点,

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include<math.h>
using namespace std ;
#define esp 1e-9
struct node{
    double x , y ;
}p[1100] ;
int n;
bool cmp(node a,node b)
{
    return ( a.x < b.x || ( a.x == b.x && a.y < b.y ) ) ;
}
bool judge(double x,double y)
{
    int low = 1 , mid , high = n;
    while( low <= high )//边界控制是个大问题!!!
    {
        mid = (low + high) / 2 ;
        if( fabs(p[mid].x-x) < esp && fabs(p[mid].y-y) < esp )
            return true ;
        else if( p[mid].x-x > esp || ( fabs(p[mid].x-x) < esp && p[mid].y-y > esp ) )
            high = mid-1 ;
        else
            low = mid +1 ;
    }
    return false ;
}
int main()
{
    int  i,j,num ;
    while( scanf("%d", &n) && n )
    {
        num=0 ;
        for(i = 1 ; i <= n ; i++)
            scanf("%lf %lf", &p[i].x, &p[i].y) ;
        sort(p+1,p+n+1,cmp) ;
        for(i = 1 ; i <= n ; i++)
            for(j = i+1 ; j <= n ; j++)
            {
                double x=(p[i].x+p[j].x)/2 ;
                double y = (p[i].y+p[j].y)/2 ;
                double xx = p[i].x - x ;
                double yy = p[i].y - y ;
                if( judge(x+yy,y-xx) && judge(x-yy,y+xx) )
                    num++ ;
            }
        printf("%d\n", num/2) ;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值