[DFS]NYOJ 927 The partial sum problem

The partial sum problem
时间限制:1000 ms | 内存限制:65535 KB

描述
One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K.
输入
There are multiple test cases.
Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents Ai.The third line contains an integer K(-10^8≤K≤10^8).
输出
If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15
样例输出
Of course,I can!
Sorry,I can’t!

这是一道DFS题,很裸,但是自己没有DFS的思想所以做了好久….

//已AC代码

#include<iostream>
#include<string.h>
#include<cstdio>
using namespace std;

int n;  //n numbers
int a[1000];
int aim;

bool dfs(int i,int sum)
{
    if(i==n)
        return sum==aim;
    if(dfs(i+1,sum))
    {
        return true;
    }
    if(dfs(i+1,sum+a[i]))
    {
        return true;
    }
    return false;
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        scanf("%d",&aim);
        if(dfs(0,0))
        {
            puts("Of course,I can!");
        }
        else
            puts("Sorry,I can't!");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值