[BFS] poj - 3984 迷宫问题

Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

题意: 给定一个迷宫,求出左上角到右下角的最短路径.

//已AC代码
#include<iostream>
using namespace std;

int a[6][6]={0};
int vis[6][6]={0};
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};  //四个方向


struct Node
{
    int x,y,pre;
}queue[30];

int front=0;
int rear=0;

void bfs(int beginx,int beginy,int endx,int endy)
{
    queue[0].x=beginx,queue[0].y=beginy,queue[0].pre=-1;
    rear++;
    vis[0][0]=1;
    while(front<rear)
    {
        for(int i=1;i<=4;i++)
        {
            int newx=queue[front].x+dir[i][0];
            int newy=queue[front].y+dir[i][1];
            if(newx<0||newx>5||newy<0||newy>5||a[newx][newy]==1||vis[newx][newy]==1)
            continue;
            queue[rear].x=newx;
            queue[rear].y=newy;
            queue[rear].pre=front;
            rear++;
            vis[newx][newy]=1;
            if(newx==endx&&newy==endy){
                return;
            }

        }
        front++;
    }
}
void print(Node now)
{
    if(now.pre==-1)
        cout<<"("<<now.x<<", "<<now.y<<")"<<endl;
    else
    {
        print(queue[now.pre]);
        cout<<"("<<now.x<<", "<<now.y<<")"<<endl;
    }
}

int main()
{
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            cin>>a[i][j];
        }
    }
    bfs(0,0,4,4);
    print(queue[rear-1]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值