hdoj 1394 Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14955    Accepted Submission(s): 9142


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

代码:


#include<stdio.h>
#include<algorithm>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=5010;
int sum[maxn<<2];
int a[maxn];
using namespace std;
void PushUP(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
} 
void build(int l,int r,int rt)
{
	sum[rt]=0;
	if(l==r)
	return ;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
}
void update(int p,int l,int r,int rt)
{
	if(l==r)
	{
		sum[rt]++;
		return ;
	}
	int m=(r+l)>>1;
	if(p<=m)
	update(p,lson);
	else
	update(p,rson);
	PushUP(rt);
}
int query(int L,int R,int l,int r,int rt)
{
	if(L<=l&&R>=r)
	{
		return sum[rt];
	}
	int ret=0;
	int m=(l+r)>>1;
	if(L<=m)
	ret+=query(L,R,lson);
	if(R>m)
	ret+=query(L,R,rson);
	return ret;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		build(0,n-1,1);
		int sum=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			sum+=query(a[i],n-1,0,n-1,1);
			update(a[i],0,n-1,1);
		}
		int ret=sum;
		for(int i=0;i<n;i++)
		{
			sum+=n-a[i]-a[i]-1;
			ret=min(ret,sum);
		}
		printf("%d\n",ret);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值