1096 Consecutive Factors (20分)【数学问题】

1096 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

解题思路:

给出一个整数,要你求其最多的连续因子个数,以及其因子。首先我们知道,一个数n一定不会被大于\sqrt{n}的数整除,因此我们只需要遍历2~\sqrt{n}的数,求此时n能最多被多少个连续整数的乘积整除。

注意:如果遍历结束后发现\sqrt{n}中不存在能整除n的连续整数,因此答案就是n本身。

#include<iostream>
#include<math.h>
using namespace std;
#define ll long long

int main()
{
	ll n;
	ll maxlen = 0, pos = 0;
	cin >> n;
	for (ll i = 2; i < sqrt(n); i++)    
	{
		ll product = 1;   //当前连续整数的乘积
		ll j = i;
		while (1)
		{
			product *= j;
			if (n%product != 0)    //不能整除结束
				break;
			if (j - i + 1 > maxlen)   //更新最大长度
			{
				pos = i;
				maxlen = j - i + 1;
			}
			j++;
		}
	}
	if (maxlen == 0)
	{
		cout << 1 << endl << n << endl;
	}
	else
	{
		cout << maxlen << endl;
		for (ll i = 0; i < maxlen; i++)
		{
			cout << pos++;
			if (i < maxlen - 1)
				cout << "*";
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值