POJ1248 Safecracker【DFS】

Description

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w2 + x3 - y4 + z5 = target


"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 92 + 53 - 34 + 25 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."
"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations.

Input

Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input.

Output

For each line output the unique Klein combination, or 'no solution' if there is no correct combination. Use the exact format shown below."

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

解题思路

 题目大意:有一个数字target和一个字符串s,请你从给定的字符串s中选出五个字母,字母的大小按照字母表的顺序,比如(A=1, B=2, …, Z=26)。假设依次选出的字母为v、w、x、y、z 使其满足以下式子
v - w^2 + x^3 - y^4 + z^5 = n
比如:给出一个n = 1 和字符串 ABCDEFGHIJKL,一个可能的结果为FIECB,6 - 9^2 + 5^3 - 3^4 + 2^5 = 1。但是注意,可能有多个满足条件的解,请输出满足条件字典序最大的字符串,”0 END”结束

思路:使用dfs遍历所有的组合情况,注意使用一个vis数组记录访问情况,因为每个字母只能访问一次。另外还需要注意,这里我使用了string类型的tmp存储每一次种组合,在回溯时我使用了string.erase()对其进行回溯。
 

代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<algorithm>
#include<functional>
using namespace std;
string s, tmp, ans;
int target;
int vis[30] = { 0 };

int fun(char c)    //将字母转化为值
{
	return c - 'A' + 1;
}

int formula(int v, int w, int x, int y, int z)    //计算公式
{
	if(v - w*w + x*x*x - y*y*y*y + z*z*z*z*z == target) 
		return 1;  
    else return 0;
}

void dfs(int cnt)
{
	if (cnt == 5)
	{
		if (formula(fun(tmp[0]), fun(tmp[1]), fun(tmp[2]), fun(tmp[3]), fun(tmp[4]))&&tmp>ans)     //判断是否满足条件
		{
			ans = tmp;
		}
	}
	else
	{
		for (int i = 0; i < s.length(); i++)
		{
			if (vis[fun(s[i])]!=1)
			{
				tmp+= s[i];
				vis[fun(s[i])] = 1;
				dfs(cnt + 1);
				tmp.erase(tmp.end() - 1);   //回溯
				vis[fun(s[i])] = 0;
			}
		}
	}
}

int main()
{
	while (1)
	{
		ans = tmp = "";
		memset(vis, 0, sizeof(vis));
		cin >> target >> s;
		if (target == 0 && s == "END")break;
		dfs(0);
		if(ans!="")
			cout << ans << endl;
		else
			cout << "no solution" << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值