HDU-1015 Safecracker

HDU-1015 Safecracker

Time Limit : 2000/1000ms (Java/Other)
Memory Limit : 65536/32768K (Java/Other)

Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST ===
“The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein’s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, …, Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.”
v - w^2 + x^3 - y^4 + z^5 = target
“For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn’t exist then.”
=== Op tech directive, computer division, 2002/11/02 12:30 CST ===
“Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution’ if there is no correct combination. Use the exact format shown below.”

Input

输入包含一行或多行,其中包含一个不超过1200万的正整数,一个空格,然后至少5个,最多十二个不同的大写字母,输入0和字母END;表示输入结束,

Output

对于每行输出的克莱因组合,输出字典序最大的一个组合,如果没有正确的组合,就输出”no solution”。

Sample Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
Sample Output
LKEBA
YOXUZ
GHOST
no solution


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1015

分析

题意:根据输入的数据,找到一个组合,使得v-w ^ 2 + x ^ 3 - y ^ 4 + z ^ 5 = target,并输出字典序最大的一个组合。

思路:用深搜即可,搜到第5个字母搜索结束,判断一下是否满足公式。因为要输出字典序最大的那一组,所以每搜索到一个符合的组合,就要比较一下;还有一种方法,就是将输出的字符串按照从大到小重新排序一下,那么搜索到的第一个符合的组合就是字典序最大的组合。如果没有符合的组合直接输出“no solution”。

代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
char answer[6],chara[13],asr[6];
int vis[13];
int n;
void DFS(int t)
{
    if (t==5)
    {
        answer[5]='\0';
        int num1=answer[0]-'A'+1;
        int num2=(answer[1]-'A'+1)*(answer[1]-'A'+1);
        int num3=(answer[2]-'A'+1)*(answer[2]-'A'+1)
        *(answer[2]-'A'+1);
        int num4=(answer[3]-'A'+1)*(answer[3]-'A'+1)
        *(answer[3]-'A'+1)*(answer[3]-'A'+1);
        int num5=(answer[4]-'A'+1)*(answer[4]-'A'+1)
        //这里不能用pow函数求次方,因为pow函数有误差,会影响正确结果。
        if (num1-num2+num3-num4+num5==n)
        {
            if (strcmp(answer,asr)>0)
                strcpy(asr,answer);
        }
        return ;
    }
    for (int i=0;i<strlen(chara);i++)
    {
        if (!vis[i])
        {
            answer[t]=chara[i];
            vis[i]=1;
            DFS(t+1);
            vis[i]=0;
        }
    }
}
int main()
{
    while (~scanf("%d %s",&n,chara))
    {
        memset(vis,0,sizeof(vis));
        if (n==0&&strcmp(chara,"END")==0)
            break;
        strcpy(asr,"@");
        DFS(0);
        if (strcmp(asr,"@")==0)
            cout<<"no solution"<<endl;
        else
            cout<<asr<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值