POJ2458 Highways【最小生成树、Prim】

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

解题思路

题目大意:给定你n个村庄,以及n个村庄之间的连接关系(距离),然后要你在这些村庄之间修路,使得所有村庄之间可以互达且修路的总距离最小,即要你求最小生成树。

思路:最小生成树的模板题,不过最终答案要你输出的是这个最小生成树中的最长的那条路的长度。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define inf 0x3f3f3f3f
int map[510][510];
int n, ans;
int dist[510];
int vis[510] = { 0 };

void prime(int start)
{
	memset(vis, 0, sizeof(vis));
	for (int i = 1; i <= n; i++)
	{
		dist[i] = inf;
	}
	dist[start] = 0;
	for (int i = 1; i <= n; i++)
	{
		int u = -1, MIN = inf;
		for (int j = 1; j <= n; j++)
		{
			if (vis[j] == 0 && dist[j] < MIN)
			{
				u = j;
				MIN = dist[j];
			}
		}
		if (u == -1)break;
		vis[u] = 1;
		if (ans < dist[u])
			ans = dist[u];
		for (int v = 1; v <= n; v++)
		{
			if (vis[v] == 0 && map[u][v] != 0 && map[u][v] < dist[v])
				dist[v] = map[u][v];
		}
	}
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		ans = 0;
		getchar();
		scanf("%d", &n);
		for(int i = 1;i<=n;i++)
			for (int j = 1; j <= n; j++)
			{
				scanf("%d", &map[i][j]);
			}
		prime(1);
		printf("%d\n", ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值