ZOJ-1090-The Circumference of the Circle(计算几何,海伦公式,三角形外接圆半径公式,cout输出小数的一些问题)

The Circumference of the Circle


Time Limit: 1 Second       Memory Limit: 32768 KB

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?

You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing six real numbers  x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

Output Specification

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

Sample Input

0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0

Sample Output

3.14
4.44
6.28
31.42
62.83
632.24
3141592.65
 
给出圆上的三点求圆的周长,给出的三点构成圆的内接三角形,可以求出三角形三边的长度,由海伦公式可以求出三角形面积:
已知三角形三边a,b,c,则 
  p=(a+b+c)/2
  S=√[p(p-a)(p-b)(p-c)] 
已知三角形面积可以由三角形外接圆半径公式求出外接圆的半径:
由正弦定理,a/sinA=b/sinB=c/sinC=2R,得sinA=a/(2R),又三角形面积公式S=(bcsinA)/2,所以S=(abc)/(4R),故R=(abc)/(4S).
然后即可求出圆的周长

#include <iostream>
#include <cmath>
#include <iomanip>
using namespace std;
const double pi=3.141592653589793;
int main()
{
	double x1,y1,x2,y2,x3,y3,a,b,c,st,cir,r,p;
	while(cin>>x1>>y1>>x2>>y2>>x3>>y3)
	{
		a=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
		b=sqrt((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3));
		c=sqrt((x3-x2)*(x3-x2)+(y3-y2)*(y3-y2));

		p=(a+b+c)/2;

		st=sqrt(p*(p-a)*(p-b)*(p-c));//三角形面积,海伦公式

		r=a*b*c/(4*st);

		cir=2*pi*r;

		cout.setf(ios::fixed);
		cout.precision(2);
		cout<<cir<<endl;
	}
	return 0;
}
cout.setf(ios::fixed);不设置为定点小数的话,cout.precision(2)指的是有效位数为2,如3.1;
 设置为定点小数后,cout.precision(2)指的是小数有效位数为2,如3.14

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值