Alice and Bob HDU4268

Alice and Bob
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5584    Accepted Submission(s): 1736

Problem Description

Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
Input

The first line of the input is a number T (T <= 40) which means the number of test cases. 
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.

Output

For each test case, output an answer using one line which contains just one number.

Sample Input

2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5

3 4 


Sample Output


1

2

题意:问A最多覆盖B能覆盖多少。

思路:贪心

#include<set>
#include<map>
#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define maxn 100005
#define maxm 100005
#define mod 1000000007
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
struct node{
    ll x,y;
}a[maxn],b[maxn];
bool cmp(node m,node n){
    if(m.x==n.x)
        return m.y>n.y;
    return m.x>n.x;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        multiset<ll>s;s.clear();
        int n;
        scanf("%d",&n);
        mem(a,0);mem(b,0);
        for(int i=0;i<n;i++)scanf("%lld%lld",&a[i].x,&a[i].y);
        for(int i=0;i<n;i++)scanf("%lld%lld",&b[i].x,&b[i].y);
        sort(a,a+n,cmp);
        sort(b,b+n,cmp);
        int x=0,ans=0;
        for(int i=0;i<n;i++){
            int j=x;
            for(j=x;a[j].x>=b[i].x&&j<n;j++)s.insert(a[j].y);
            x=j;int z=*s.lower_bound(b[i].y);
            if(z>=b[i].y){s.erase(z);}
            else {ans++;}
        }
        printf("%d\n",n-ans);
    }
}






 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值