2016多校训练Contest6: 1008 To My Girlfriend hdu5800

Problem Description
Dear Guo

I never forget the moment I met with you.You carefully asked me: "I have a very difficult problem. Can you teach me?".I replied with a smile, "of course"."I have n items, their weight was a[i]",you said,"Let's define f(i,j,k,l,m) to be the number of the subset of the weight of n items was m in total and has No.i and No.j items without No.k and No.l items.""And then," I asked.You said:"I want to know
i=1nj=1nk=1nl=1nm=1sf(i,j,k,l,m)(i,j,k,laredifferent)


Sincerely yours,
Liao
 

Input
The first line of input contains an integer T (T15)  indicating the number of test cases.
Each case contains 2 integers  n s   (4n1000,1s1000) . The next line contains n numbers:  a1,a2,,an   (1ai1000) .
 

Output
Each case print the only number — the number of her would modulo  109+7  (both Liao and Guo like the number).

 

Sample Input
  
  
2 4 4 1 2 3 4 4 4 1 2 3 4
 

Sample Output
  
  
8 8

F[i][j][k][l]表示前i个数和为j必须选的选了k个必须不选的选了l个的方案数

直接转移就可以了

最后答案要乘上4

#include<map>
#include<cmath>
#include<queue>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int mod=1000000007;
int f[1001][1001][3][3];
int a[1001];
int main()
{
	int T;
	scanf("%d",&T);
	while(T>0)
	{
		T--;
		int n,s;
		scanf("%d%d",&n,&s);
		int i,j,k,l;
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		//memset(f,0,sizeof(f));
		f[0][0][0][0]=1;
		for(i=1;i<=n;i++)
		{
			for(j=0;j<=s;j++)
			{
				for(k=0;k<=2;k++)
				{
					for(l=0;l<=2;l++)
					{
						f[i][j][k][l]=f[i-1][j][k][l];
						if(a[i]<=j)
						{
							f[i][j][k][l]=(f[i][j][k][l]+f[i-1][j-a[i]][k][l]);
							if(f[i][j][k][l]>=mod)
								f[i][j][k][l]-=mod;
						}
						if(k>0&&a[i]<=j)
						{
							f[i][j][k][l]=(f[i][j][k][l]+f[i-1][j-a[i]][k-1][l]);
							if(f[i][j][k][l]>=mod)
								f[i][j][k][l]-=mod;
						}
						if(l>0)
						{
							f[i][j][k][l]=(f[i][j][k][l]+f[i-1][j][k][l-1]);
							if(f[i][j][k][l]>=mod)
								f[i][j][k][l]-=mod;
						}
					}
				}
			}
		}
		long long ans=0;
		for(i=2;i<=s;i++)
			ans=(ans+f[n][i][2][2])%mod;
		printf("%I64d\n",ans*(long long)4%mod);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值