Andy's First Dictionary

Andy, 8, has a dream - he wants to produce his
very own dictionary. This is not an easy task for
him, as the number of words that he knows is,
well, not quite enough. Instead of thinking up all
the words himself, he has a briliant idea. From
his bookshelf he would pick one of his favourite
story books, from which he would copy out all
the distinct words. By arranging the words in
alphabetical order, he is done! Of course, it is
a really time-consuming job, and this is where a
computer program is helpful. 这里写图片描述
story books, from which he would copy out all
the distinct words. By arranging the words in
alphabetical order, he is done! Of course, it is
a really time-consuming job, and this is where a
computer program is helpful.
You are asked to write a program that lists
all the different words in the input text. In this
problem, a word is de ned as a consecutive se-
quence of alphabets, in upper and/or lower case.
Words with only one letter are also to be considered. Furthermore, your program must be CaSe In-
SeNsItIvE. For example, words like \Apple”, \apple” or \APPLE” must be considered the same.
Input
The input le is a text with no more than 5000 lines. An input line has at most 200 characters. Input
is terminated by EOF.
Output
Your output should give a list of different words that appears in the input text, one in a line. The
words should all be in lower case, sorted in alphabetical order. You can be sure that he number of
distinct words in the text does not exceed 5000.
Sample Input
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: “Disneyland Left.”
So they went home.
Sample Output
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when
分析:

/*输入一个文本,找出所有不同的单词(连续的字母序列),
按照字典序从小到大输出单词不区分大小写*/
//ps 对于缩写 I'm 去除'后为I和m两个单词

用到的函数:

1.isalpha()判断字符是否为英文字母,若为英文字母,返回非0(小写字母为2,大写字母为1)。若不是字母,返回0
2.//tolower()功能是把字母字符转换成小写,非字母字符不做出处理

代码总览:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <set>
using namespace std;
set<string>s1;
int main()
{
    string str,str1;
    while(cin>>str)
    {
        for(int i=0;i<str.length();i++)
        {
            if(isalpha(str[i]))
            {
                str[i]=tolower(str[i]);
                str1+=str[i];
            }
            else{
             if(str1.length())
             {
                s1.insert(str1);
                str1.clear();
             }//这里当输入的字符不是英文字符时,进行的处理,放在set中,分段处理
            }
        }
        if(str1.length())
        {
            s1.insert(str1);
            str1.clear();
        }
    }
    set<string>::iterator it;
    for(it=s1.begin();it!=s1.end();it++)
    {
        cout<<*it<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值