杭电 HDU ACM 1405 The Last Practice

The Last Practice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8374    Accepted Submission(s): 1724


Problem Description
Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
 

Input
Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it  should not to be processed.
 

Output
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.
 

Sample Input
  
  
60 12 -1
 

Sample Output
  
  
Case 1. 2 2 3 1 5 1 Case 2. 2 2 3 1
Hint
60=2^2*3^1*5^1
 

Author
lcy
 
 
这个题目气的我头疼,以前做过类似的题目 ,思路先是 素数打表,然后依次检索并记录素数因子,重复此过程直到,n==1;不过不幸的是超时。参考了网上的方法。
不好理解,可以这样想。一个数既然可以表示某些素数的乘积,那么对于一个数n,从2开始检索n的所有因子,那么既然是n的因子,必然为质数,反证:如果某个i为合数,
那么必然又能写成两小一点儿得数乘积,早就应该被从2开始的因子分解掉了,不可能发生,那么只能是质数了。
 
这个是超时的:
#include<iostream>
#include<cmath>
#include<string.h>
using namespace std;
int ls[65539];
int cnt[1000];
int u=0;
void prime()
{
	for(int i=1;i<=65537;i++)
	ls[i]=1;
	for(int j=2;j<sqrt(65537);j++)
	{
		if(ls[j])
		{
			for(int k=j+j;k<=65537;k+=j)
				ls[k]=0;
		}
	}
	
	for(int r=2;r<=65537;r++)
	{
		if(ls[r])
			cnt[u++]=r;
	}
			
}

int main()
{
	int n;int gq[65540];int h=1;
    prime();
	while(cin>>n&&n>0)
	{	
		memset(gq,0,sizeof(gq));
		for(int x=0;x<u;x++)
		{
			if(n%cnt[x]==0)
			{
				gq[cnt[x]]++;
			n/=cnt[x];
			}
			if(n==1)
				break;
			else if(n<=cnt[x])
				x=-1;
			
		}
		
		cout<<"Case "<<h++<<"."<<endl;
		for(int p=0;p<=65534;p++)
		{
			if(gq[p])
				cout<<p<<" "<<gq[p]<<" ";
		}
		cout<<endl<<endl;
	}
	return 0;
}

AC Code:
#include<iostream>
using namespace std;
int main()
{
	int n,ls[100],gq[50],flag=0,t=1;
	while(cin>>n&&n>0)
	{
		if(flag)
			cout<<endl;
		memset(ls,0,sizeof(ls));
		memset(gq,0,sizeof(gq));
		int k=0;
		for(int i=2;n!=1;i++)
		{
			if(n%i==0)
			{
				ls[k]=i;
				while(n%i==0)
				{
					gq[k]++;
					n/=i;
				}
				k++;
			}
			
		}
		
		cout<<"Case "<<t++<<"."<<endl;
		for(int m=0;m<k;m++)
			cout<<ls[m]<<" "<<gq[m]<<" ";
		cout<<endl;
		flag=1;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值