杭电-The Last Practice

The Last Practice

Problem Description

Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input

Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60
12
-1

Sample Output

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1

Tips:
60=2^2*3^1*5^1

被坑了无数次的我代码如下
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <iomanip>
using namespace std;

int main()
{
    int n,num,th= 1;
    while (cin>>n&& n > 0)
    {
        if (th!=1) cout<<endl;
        cout<<"Case "<<th++<<"."<<endl;
        for (int i=2;i<=n;++i)
        {
            num=0;
            if (n%i==0)
            {
                cout<<i<<" ";
            }
            while (n%i==0)
            {
                num++;
                n/=i;
            }
            if (num>0) cout<<num<<" ";
        }
        cout<<endl;
    }
    return 0;
}
心得:
非常暴力的解法,其实我在网上看到有人先求2的,效率更高一些,不过先这样吧,已经被逼疯。。。
图片:


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值