杭电-1325 Is It A Tree?(有向图回路)

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21602    Accepted Submission(s): 4865

Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 
Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 
Sample Input
  
  
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 
Sample Output
  
  
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 
Source
 
Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1233  1102  1875  1879  1301 

解题思路:
这道题的确挺坑的,刚一看题,以为和前面的那道题一样,就改了输出提交,WA了无数次!后来看了一下讨论区,
才知道,那道题是无向图,这道题有方向,还要判断一下他的入度,如果存在入度大于1,不符合; (树的每个节点入度小于2)
AC代码:
#include<stdio.h>
#include<string.h>
#define max 1000+10
int set[max],in[max];//set记录父节点,in记录入度 
int find(int p)
{
    while(p!=set[p])
      p=set[p];
    return p;
}
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    set[fx]=fy;
}
int main()
{
    int i,j,a,b,exist,t=1,sum,wrong;
    while(1)
    {
        memset(set,0,sizeof(set));
        memset(in,0,sizeof(in)); 
        exist=0;
        while(scanf("%d%d",&a,&b)&&(a!=0||b!=0))
        {
            if(a<0&&b<0)
            return 0;
            if(set[a]==0) set[a]=a;
            if(set[b]==0) set[b]=b;
            in[b]++;
            if(find(a)==find(b)) exist=1;
            merge(a,b);
        }
        if(exist)
        {
            printf("Case %d is not a tree.\n",t++);
        }
        else
        {
            sum=0;wrong=0;
            for(i=1;i<max;i++)
            {
                if(set[i]==i)//判断是否连通
                {
                    sum++;
                    if(sum>1)//没有连通 
                    {
                        wrong=1;
                        break;
                    }
                } 
                if(in[i]>1)//入度大于1
                {
                    wrong=1;
                    break;
                } 
            }
            if(wrong)
            printf("Case %d is not a tree.\n",t++);
            else
            printf("Case %d is a tree.\n",t++);
        }
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值