杭电1325Is It A Tree?

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21769    Accepted Submission(s): 4915


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 

Sample Input
  
  
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
  
  
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 
没看清题意,以为当输入-1,-1,时结束循环,其实是小于零时结束循环,错了一个晚上 
开始写的是while(scanf("%d%d",&a,&b)&&(a!=-1&&b!=-1))
一直 Time Limit Exceeded
然后写while(~scanf("%d%d",&a,&b))
      {
    if(a!=-1&&b!=-1)
    break;
       } 又是wrong answer 
最后写if(a<0&&b<0) break; ac了
还有 if(a==0&&b==0)
{
printf("Case %d is a tree.\n",l++);
continue;
}
可以不写也ac; 


#include<stdio.h>
#include<string.h>
int ans;
int pre[100010],visit[100010];
int find(int x)
{
	while(x!=pre[x])
	x=pre[x];
	return x;
}
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	visit[x]=1;
	visit[y]=1;
	if(fx==fy||fy!=y)
	{
		ans=1;
		return ;
	}
	pre[fy]=fx;
}
int main()
{
	int a,b,c,d,i;
	int l=1;
	while(~scanf("%d%d",&a,&b))
	{
		if(a<0&&b<0)
		break;
		if(a==0&&b==0)
		{
			printf("Case %d is a tree.\n",l++);
			continue;
		}
		for(i=1;i<100010;i++)
		pre[i]=i;
		memset(visit,0,sizeof(visit));
		merge(a,b);
		ans=0;
		while(scanf("%d%d",&c,&d),c||d)
			merge(c,d);
		if(ans)
		{
			printf("Case %d is not a tree.\n",l++);
			continue;
		}
			int sum=0;
			for(i=1;i<100010;i++)
			if(visit[i]&&pre[i]==i)
			sum++;
			if(sum>1)
			printf("Case %d is not a tree.\n",l++);
			else
			printf("Case %d is a tree.\n",l++);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值