Light OJ 1307 - Counting Triangles(lower_bound)

Description

You are given N sticks having distinct lengths; you have to form some triangles using the sticks. A triangle is valid if its area is positive. Your task is to find the number of ways you can form a valid triangle using the sticks.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with a line containing an integer N (3 ≤ N ≤ 2000). The next line contains N integers denoting the lengths of the sticks. You can assume that the lengths are distinct and each length lies in the range [1, 109].

Output

For each case, print the case number and the total number of ways a valid triangle can be formed.

Sample Input

3

5

3 12 5 4 9

6

1 2 3 4 5 6

4

100 211 212 121

Sample Output

Case 1: 3

Case 2: 7

Case 3: 4

AC代码:
#include<cstdio>  
#include<cstring>  
#include<stack>  
#include<algorithm>  
using namespace std;  
#define LL long long  
LL shu[2010],s;  
int main()  
{  
    int t;scanf("%d",&t); 
	int k=0; 
    while(t--)  
    {  
        int n;
		scanf("%d",&n);  
        for (int i=0;i<n;i++)  
            scanf("%lld",&shu[i]);  
        sort(shu,shu+n);  
        shu[n]=1111111111000;  
        s=0;  
        for (int i=0;i<n-2;i++)  
        {  
            for (int j=i+1;j<n-1;j++)  
            {  
                int c=shu[i]+shu[j];  //找出两边的和; 
                int kk=lower_bound(shu,shu+n+1,c)-shu;  //找出第一个大于等于两边和的位置 
                s+=kk-j-1;  
            }  
        }  
        printf("Case %d: %lld\n",++k,s);  
    }  
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值