Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
/*
* File: main.cpp
* Author: LeeningLu
*
* Created on 2012年3月27日, 下午3:01
*/
#include<stdio.h>
#include<memory.h>
#define M 1010
int T;
int N;//骨头数量
int V;//背包容量
struct bone{
int value;//骨头价值
int volume;//骨头所占背包容量
}bone[M];
int bag[M];
int main(void)
{
scanf("%d",&T);
while(T--){
scanf("%d%d",&N,&V);//读取骨头数量和背包容量
for(int i=1;i<=N;i++)
scanf("%d",&bone[i].value);//读取每个骨头的价值
for(int i=1;i<=N;i++)
scanf("%d",&bone[i].volume);//读取每个骨头所占背包容量
memset(bag,0,sizeof(bag));//初始化数组
for(int j=1;j<=N;j++){
for(int i=V;i>=0;i--){//背包从大到小开始搜索是因为,如果从小到大开始搜索,有时会把一块骨头重复搜索两次
if(i>=bone[j].volume&&bone[j].value+bag[i-bone[j].volume]>bag[i])
//状态转移方程max{bone[j].value+bag[i-bone[j].volume],bag[i]}
}
}
printf("%d\n",bag[V]);
}
return 0;
}