bellmanford(poj3259 wormholes)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 59980 Accepted: 22417

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

POJ 3259

农夫约翰在探索他的许多农场,发现了一些惊人的虫洞。虫洞是很奇特的,因为它是一个单向通道,可让你进入虫洞的前达到目的地!他的N(1≤N≤500)个农场被编号为1..N,之间有M(1≤M≤2500)条路径,W(1≤W≤200)个虫洞。FJ作为一个狂热的时间旅行的爱好者,他要做到以下几点:开始在一个区域,通过一些路径和虫洞旅行,他要回到最开时出发的那个区域出发前的时间。也许他就能遇到自己了:)。为了帮助FJ找出这是否是可以或不可以,他会为你提供F个农场的完整的映射到(1≤F≤5)。所有的路径所花时间都不大于10000秒,所有的虫洞都不大于万秒的时间回溯。

 

输入

第1行:一个整数F表示接下来会有F个农场说明。

每个农场第一行:分别是三个空格隔开的整数:N,M和W

第2行到M+1行:三个空格分开的数字(S,E,T)描述,分别为:需要T秒走过S和E之间的双向路径。两个区域可能由一个以上的路径来连接。

第M +2到M+ W+1行:三个空格分开的数字(S,E,T)描述虫洞,描述单向路径,S到E且回溯T秒。

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

输出

F行,每行代表一个农场

每个农场单独的一行,” YES”表示能满足要求,”NO”表示不能满足要求。

NO
YES
注意:
两块地之间的路径是双向路径;
虫洞的路径是单向路径。


分析:

看图中有没有负权环,有的话John可以无限次走这个环,使得时间一定能得到一个负值。所以有的存在负环话就是可以,没有的话就是不可以了。

#include<iostream>
#include<cstring>
using namespace std;
#define Max 99999
struct
{
	int start,end,time;
}edge[6000];
int point_num,edge_num,dis[505];
bool bellmanford()
{
	for(int i=2;i<=point_num;i++) dis[i]=Max;
	for(int i=1;i<point_num;i++)
	{
		bool finish=true;//全部完成松弛的判断 
		for(int j=1;j<=edge_num;j++)
		{
			int u=edge[j].start;
			int v=edge[j].end;
			int w=edge[j].time;
			if(dis[v]>dis[u]+w)//松弛 
			{
				dis[v]=dis[u]+w;
				finish=false;
			}
		}
		if(finish) break;
	}
	for(int i=1;i<=edge_num;i++)//是否存在负环的判断 
	{
		int u=edge[i].start;
		int v=edge[i].end;
		int w=edge[i].time;
		if(dis[v]>dis[u]+w) return true;
	}
	return false;
}
int main()
{
	int farm;
    cin>>farm;
    while(farm--)
    {
    	int field,path,hole;
    	cin>>field>>path>>hole;
    	int s,e,t,i,k=0;
    	for(int i=1;i<=path;i++)
    	{
    		cin>>s>>e>>t;
    		k++;
    		edge[k].start=s;
    		edge[k].end=e;
    		edge[k].time=t;
    		k++;
    		edge[k].start=e;
    		edge[k].end=s;
    		edge[k].time=t;
		}
		for(int i=1;i<=hole;i++)
		{
			cin>>s>>e>>t;
			k++;
			edge[k].start=s;
    		edge[k].end=e;
    		edge[k].time=-t;
		}
		point_num=field;
		edge_num=k;
		if(bellmanford()) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值