1010. 一元多项式求导 (25)

1010. 一元多项式求导 (25)

时间限制 400 ms
内存限制 65536 kB
代码长度限制 8000 B
判题程序 Standard

设计函数求一元多项式的导数。(注:xn(n为整数)的一阶导数为n*xn-1。)

输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是0,但是表示为“0 0”。

输入样例:
3 4 -5 2 6 1 -2 0

输出样例:
12 3 -10 1 6 0

原题地址: https://www.patest.cn/contests/pat-b-practise/1010


注意一下求导为0的项不输出, 当整个求导多项式都为0时,要输出“0 0”

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cctype>
using namespace std;

void solve()
{
    int a[5000], n = 0;

    char ch;
    char str[10000] = {0};
    gets(str);
    for(int i = 0; str[i]; ){
        if(str[i] != ' '){
            a[n ++] = atoi(str + i);
            while(str[i] && str[i] != ' ')
                i ++;
        }
        else{
            i ++;
        }

    }

    int b[n], n_ = 0;
    for(int i = 0; i < n; i += 2){
        if(a[i] * a[i + 1]){
            b[n_] = a[i] * a[i + 1];
            b[n_ + 1] = a[i + 1] - 1;
            n_ += 2;
        }
    }

    if(!n_){
        cout << "0 0" << endl;
        return ;
    }

    for(int i = 0; i < n_; i += 2){
        cout << b[i] << " " << b[i + 1];
        if(i + 2 < n_)
            cout << " ";
    }
    cout << endl; 
}

int main()
{
    solve();
    return 0;
}

别的精简代码:

#include <stdlib.h>
#include <string.h>
#include <iostream>

using namespace std;

int main()
{
    int a,b;
    int flag = 0;
    b = 1;
    while(cin>>a>>b)
    {
        if(b>0)
            if(flag ==0)
            {
                cout<<a*b<<' '<<b-1;
                flag = 1;
            }
            else
                cout<<' '<<a*b<<' '<<b-1;
    }
    if(flag ==0)
        cout<<"0 0";
    system("pause");
    return 0;
}

主要是没有想到cin可以这么用,不然就不用自己写转换了。

原文: http://blog.csdn.net/wyxdexyq/article/details/38795159

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值