HDU Problem 1896

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2063    Accepted Submission(s): 1359


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output
  
  
11 12
 思路比较简单,在路上遇见遇到第奇数个石子,就把他取出来加上距离在放到队列中,如果偶数个直接取出。如果同一个位置有多个石子,先看到拽的最近的,这就用到了有限对列。
#include <cmath>
#include <queue>
#include <stack>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 1005
using namespace std;
const int INF = 0xffff;

struct node{
    int p, d;
    friend bool operator < (node a, node b) {
        if (a.p == b.p) return a.d > b.d;
        return a.p > b.p;
    }
}temp;

int main() {
    int n, a, b, t, c;
    scanf("%d", &t);
    while (t--) {
        priority_queue<node> que;
        while (!que.empty()) que.pop();
        scanf("%d", &n);
        for (int i = 0; i < n; i++) {
            scanf("%d%d", &a, &b);
            temp.d = b;
            temp.p = a;
            que.push(temp);
        }
        int cnt = 1;
        while (!que.empty()) {
        	
			//如果碰见的是奇数,就取出后加上扔的距离放到队里
            if (cnt&1) {
                temp = que.top();
                c = temp.p;
                temp.p += temp.d;
                que.push(temp);
                que.pop();
            }
            else {
                c = que.top().p;
                que.pop();
            }
            cnt++;
        }
        printf("%d\n", c);
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值