hdu 1896 优先队列

hdu 1896  

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2214    Accepted Submission(s): 1442


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output
  
  
11 12


//hdu 1896
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <string>
#include <queue>
using namespace std;
//遇到石头,奇数就往前扔,偶数就留着
//找出离出发点最远的石头
//注意,扔完石头的话前面的顺序又会改变了
struct Node {
	int dis;
	int d;
	friend bool operator<(Node n1, Node n2)
	{
		if (n1.dis == n2.dis)
			return n2.d < n1.d;//距离相等就把小的先弹出
		else
			return n2.dis < n1.dis;//否则就先弹出距离小的
	}
};
int main()
{
	int t;
	int n;
	int cnt;
	Node cur, next;
	int ans;
	scanf("%d", &t);
	while (t--)
	{
		priority_queue<Node> q;
		scanf("%d", &n);
		while (n--)
		{
			scanf("%d%d", &cur.dis, &cur.d);
			q.push(cur);
		}
		cnt	 = 0;
		ans = 0;
		while (!q.empty())
		{
			cnt++;
			cur = q.top();
			q.pop();

			ans = max(ans, cur.dis);
			if (cnt % 2)
			{
				next.dis = cur.dis + cur.d;
				next.d = cur.d;
				q.push(next);
			}
		}

		printf("%d\n", ans);
	}
	system("pause");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值