HDU Problem 5631 Rikka with Graph【并查集】

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1023    Accepted Submission(s): 486


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number  T(T30) ——The number of the testcases.

For each testcase, the first line contains a number  n(n100) .

Then n+1 lines follow. Each line contains two numbers  u,v  , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5780  5779  5778  5777  5776 
 

一开始被这道题给蒙了一下,要讨论多少种情况。。。。。
后来才知道,数据只有n+1条边,要想成树,最起码要有n-1条边,所以只有两种讨论的情况,删一条边或者删两条边。

#include<stdio.h>
#include<string.h>
using namespace std;
int u[121], v[121], par[121];
int n, ans;
void init() {
    for(int i = 0;i <= n;i++) {
        par[i]=i;
    }
}
int Find(int x) {
    if (x == par[x])
        return x;
    return par[x] = Find(par[x]);
}
void unite(int x, int y) {
    int fx = Find(x);
    int fy = Find(y);
    if(fx != fy) par[fx] = fy;
}
void dele1(int x) {
    init();
    for(int i=0;i<n+1;i++) {
        if(i != x) {
            unite(u[i],v[i]);
        }
    }
    int cont = 0;
    for(int i = 1;i <= n; i++) {
        if(par[i] == i) cont++;
    }
    if(cont == 1) ans++;
}
void dele2(int x,int y) {
    init();
    for(int i = 0; i < n + 1; i++) {
        if(i != x && i != y) {
            unite(u[i], v[i]);
        }
    }
    int cont = 0;
    for(int i = 1;i <= n; i++) {
        if(par[i] == i) cont++;
    }
    if(cont == 1) ans++;
}
int main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);
        for(int i = 0; i < n + 1; i++) {
            scanf("%d%d", &u[i], &v[i]);
        }
        ans = 0;
        for(int i = 0;i < n+1; i++) {
            dele1(i);
        }
        for(int i = 0;i < n+1; i++) {
            for(int j = i+1; j < n+1; j++) {
                dele2(i, j);
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值