hdu6045 Is Derek lying? -逻辑题-2017多校联盟2 1题

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 648    Accepted Submission(s): 371


Problem Description
Derek and Alfia are good friends. Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “ A ” “ B ” and “ C ”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia .Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X ,your total score is Y .”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.
 

Input
The first line consists of an integer T ,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N , X , Y ,the meaning is mentioned above.

The second line consists of N characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of Derek for each question.

The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range: 1N80000 , 0X,YN, Ti=1N300000
 

Output
For each test case,the output will be only a line.

Please print “ Lying ” if you can make sure that Derek is lying,otherwise please print “ Not lying ”.
 

Sample Input
  
  
2 3 1 3 AAA ABC 5 5 0 ABCBC ACBCB
 

Sample Output
  
  
Not lying Lying
 

Source


/*
题意:
n个选择题,选项ABC,两人分别作答,并给出两人各自得分,问此得分是否正确

题解
设N个题目中两人相同的答案数为s,那么不相同的答案数为N-s
其中相同的答案中得分的题目数为a,不得分的题目数为b,即s = a+b。
其中不相同的答案中Derek答对的有m个,那么 Alfia答对的有n个,
其中n<=N-s-m个,因为有可能两人都错;
则 x = a+m;  y <= a+N-s-m = a+N-(a+b)-m = N-b-m
那么 x+y < a+N-b
x+y-a < N-b <= N
x+y-(a+b)<=N
x+y-s<=N  ①

两个人的分数差就差在两人答案不同的题目上,
容易得证,0<=两人的分数差<=不同题目数,
即|x-y| <= N-s  ②
满足上述两个条件即可
*/

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
#include <stdlib.h>
#include <set>
#include <algorithm>
using namespace std;


int main()
{
    int t;
    int x,y;
    int n;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&n,&x,&y);
        char a[80010],b[80010];
        scanf("%s%s",a,b);
        int s = 0;
        for(int i = 0;i<n;++i){
            if(a[i]==b[i]) s++;
        }
        if(n-s >= abs(x-y) && x+y-s<=n){
            printf("Not lying\n");
        }
        else printf("Lying\n");
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值