HDOJ 6045-Is Derek lying?

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


题目链接:点击打开链接


Problem Description
Derek  and  Alfia  are good friends. Derek  is Chinese,and  Alfia  is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of  N  choice questions and each question is followed by three choices marked “ A ” “ B ” and “ C ”.Each question has only one correct answer and each question is worth  1  point.It means that if your answer for this question is right,you can get  1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell  Derek  the total score of him and  Alfia .Then  Alfia will ask  Derek  the total score of her and he will tell her: “My total score is  X ,your total score is  Y .”But  Derek  is naughty,sometimes he may lie to her. Here give you the answer that  Derek  and  Alfia  made,you should judge whether  Derek  is lying.If there exists a set of standard answer satisfy the total score that  Derek  said,you can consider he is not lying,otherwise he is lying.
 

Input
The first line consists of an integer  T ,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers  N , X , Y ,the meaning is mentioned above.

The second line consists of  N  characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of  Derek  for each question.

The third line consists of  N  characters,the same form as the second line,which represents the answer of  Alfia  for each question.

Data Range: 1N80000 , 0X,YN, Ti=1N300000
 

Output
For each test case,the output will be only a line.

Please print “ Lying ” if you can make sure that  Derek  is lying,otherwise please print “ Not lying ”.

Sample Input
2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB
 


Sample Output
Not lying
Lying


题意:D和A是好朋友,同时参加考试比赛,比赛完后,系统会告诉D他们俩的总得分情况,D比较顽皮,他有时不会向A汇报正确的得分情况, 做对一题得一分,告诉你有多少道题,以及D告诉A他和A的总分,然后分别给出D和A的答案,问你D是否对A撒谎了。


分析:假设一个人的答案全部正确为n,c是他们一样答案的个数,那么他们的的总得分一定不大于n+c,他们得分差一定不大于n-c。

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
char s1[300010],s2[300010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
       int a,b,n;
       scanf("%d %d %d",&n,&a,&b);
       scanf("%s",s1);
       scanf("%s",s2);
       int c=0;
       for(int i=0;i<n;i++)
       {
        if(s1[i]==s2[i]) c++;//c是记录他们答案相同的个数
       }
      if(a+b<=n+c&&abs(a-b)<=n-c)
      {
        printf("Not lying\n");
      }
      else
      {
        printf("Lying\n");
      }
    }
    return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值