POJ3007

Organize Your Train part II
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7938 Accepted: 2302


产分单词;


Description

RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.


Figure 1: Layout of the exchange lines

A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

  [3:1]
    abc+d  cba+d  d+abc  d+cba
  [2:2]
    ab+cd  ab+dc  ba+cd  ba+dc  cd+ab  cd+ba  dc+ab  dc+ba
  [1:3]
    a+bcd  a+dcb  bcd+a  dcb+a

Excluding duplicates, 12 distinct configurations are possible.

Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

Input

The entire input looks like the following.

the number of datasets = m
1st dataset
2nd dataset

...
m-th dataset

Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

Output

For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

Sample Input

4
aa
abba
abcd
abcde

Sample Output

1
6
12
18

Source

Japan 2006 Domestic




#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#define LL long long
using namespace std;
const int N =3e4+10;
struct node
{
    bool flag;
    int next[26];
    void clean()
    {
        flag=0;
        memset(next,-1,sizeof(next));
    }
} T[N];
int top;
int ans;
string::iterator iter;
char str[110];
int creat()
{
    T[top].clean();
    return top++;
}
void build(int p,string s)
{
    int j;
    for(iter=s.begin();iter!=s.end();iter++)
    {
        j=*iter-'a';
        if(T[p].next[j]==-1)
            T[p].next[j]=creat();
        p=T[p].next[j];
    }
    if(!T[p].flag)
    {
        T[p].flag=1;
        ans++;
    }
}

void solve(char* s1,char* s2)
{
    string c,c1,c2,c3,c4;
    c3=c1=s1,c4=c2=s2;
   //cout<<c1<<"  "<<c2<<endl;
    reverse(c3.begin(),c3.end());
   reverse(c4.begin(),c4.end());
    c=c1+c4;
    build(0,c);

    c=c3+c2;
    build(0,c);
    c=c3+c4;
    build(0,c);
    c=c2+c1;
    build(0,c);
    c=c2+c3;
    build(0,c);
    c=c4+c1;
    build(0,c);
    c=c4+c3;
    build(0,c);
}
int main()
{

    int t;
    char s1[110],s2[110];
    scanf("%d",&t);
    while(t--)
    {
        top=0;
        ans=0;
        int rt=creat();
        scanf("%s",str);
        build(0,str);
        int len=strlen(str);
        for(int i=1; i<len; i++)
        {
            strncpy(s1,str,i);
            s1[i]='\0';
            strncpy(s2,str+i,len-i);
            s2[len-i]='\0';
            solve(s1,s2);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值