POJ 3070 Fibonacci 快速矩阵幂

Language:
Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13723 Accepted: 9720

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

题目链接:http://poj.org/problem?id=3070

<span style="font-size:24px;">#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int mod=10000;
int n;
struct My{
int cun[2][2];
My operator*(const My m)const{
My temp;
for(int i=0;i<2;i++){
for(int j=0;j<2;j++){
 temp.cun[i][j]=0;
    for(int k=0;k<2;k++)
    {
        temp.cun[i][j]+=cun[i][k]*m.cun[k][j]%mod;
        temp.cun[i][j]%=mod;
    }
}
}
return temp;
}
};

int Pow(My &m,int k){
    My ans;
    memset(ans.cun,0,sizeof(ans.cun));
    for(int i = 0;i <2;i++)
        ans.cun[i][i] = 1;
    while(k){
        if(k&1){ ans = ans*m;}
        k >>= 1;
        m = m*m;
    }
    return ans.cun[0][0]%mod;
}

int  main(){
while(cin>>n&&n!=-1)
{
    if(n==0){cout<<0<<endl;continue;}
    My m;
    m.cun[0][0]=1,m.cun[1][0]=1,m.cun[0][1]=1,m.cun[1][1]=0;
int res=Pow(m,n-1);
cout<<res<<endl;
}
return 0;}</span><span style="font-size: 12pt;">
</span>

这是一个快速矩阵幂的模板题,主要有一个实现矩阵的结构体,需要重载一下结构体的乘法(根据矩阵乘法的原理),然后利用类似二分的原理,如:计算n的八次方分成了
计算n的平方,n的平方乘上n的平方。。。依次列推。可得答案。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值