POJ 3070 Fibonacci (矩阵幂运算)

Time limit
1000 ms
Memory limit
65536 kB

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

这里写图片描述
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

这里写图片描述

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

这里写图片描述

思路:矩阵快速幂+对10000取余。

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>

using namespace std;

struct Matrix // 定义矩阵 
{
    int a[2][2];
    Matrix()
    {
        memset(a,0,sizeof(a));
    }
};

Matrix mul(Matrix a,Matrix b)//矩阵乘法+取余 
{
    Matrix ans;
    for(int i=0; i<2; i++)
    {
        for(int k=0; k<2; k++)
        {
            if(a.a[i][k])
                for(int j=0; j<2; j++)
                {
                    ans.a[i][j]+=a.a[i][k]*b.a[k][j];
                    if(ans.a[i][j]>=10000)
                        ans.a[i][j]%=10000;
                }
        }
    }
    return ans;
}

int Mypow(int N)
{
    Matrix mid,re;
    mid.a[0][0] = mid.a[1][1] = 1;
    re.a[0][0] = re.a[1][0] = re.a[0][1] = 1;
    while(N)
    {
        if(N&1)mid = mul(mid,re);
        re = mul(re,re);
        N >>= 1;
    }
    return mid.a[0][1];
}

int main()
{
    int N;
    while(scanf("%d",&N) && N!=-1)
    {
        if(N == 0)
        {
            printf("0\n");
            continue;
        }
        else if(N<3)
        {
            printf("1\n");
            continue;
        }
        printf("%d\n",Mypow(N));
    }
    return 0;
}

转载于:https://www.cnblogs.com/vocaloid01/p/9514234.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值