poj1258 Agri-Net 最小生成树

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 54134 Accepted: 22479

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

分析:题目不难,就是一个裸的prim算法,甚至邻接矩阵都赤裸裸的给出来了,水水过吧。。。

代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxx=110;
const int INF=1<<20;
int cun[maxx][maxx];//存储村庄之间的距离,即题目所给的邻接矩阵
int minroad[maxx];//存储已经在最小生成树的村庄到之外村庄的距离
bool used[maxx];//存储村庄是否在最小生成树之内
int n;
int prim(){
int res=0;
while(true)
{
    int v=-1;
   for(int i=0;i<n;i++)
    {
        if(!used[i]&&(v==-1||minroad[v]>minroad[i]))v=i;
    }
    if(v==-1)break;
    res+=minroad[v];
    used[v]=true;
    for(int i=0;i<n;i++)
    {
        minroad[i]=min(minroad[i],cun[v][i]);//选择最小值
    }
}
return res;
}

void init(){
memset(used,false,sizeof(used));
for(int i=0;i<=n;i++)minroad[i]=INF;
minroad[0]=0;
}


int main(){
while(cin>>n)
{
    for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
       cin>>cun[i][j];
init();
int aa=prim();
cout<<aa<<endl;
}
return 0;}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值