POJ1054 TheTroubleFrog

The Troublesome Frog

Time Limit: 5000MS Memory Limit: 100000K
Total Submissions: 11152 Accepted: 3324
Case Time Limit: 500MS

Description

In Korea, the naughtiness of the cheonggaeguri, a small frog, is legendary. This is a well-deserved reputation, because the frogs jump through your rice paddy at night, flattening rice plants. In the morning, after noting which plants have been flattened, you want to identify the path of the frog which did the most damage. A frog always jumps through the paddy in a straight line, with every hop the same length:
这里写图片描述
Your rice paddy has plants arranged on the intersection points of a grid as shown in Figure-1, and the troublesome frogs hop completely through your paddy, starting outside the paddy on one side and ending outside the paddy on the other side as shown in Figure-2:
这里写图片描述
Many frogs can jump through the paddy, hopping from rice plant to rice plant. Every hop lands on a plant and flattens it, as in Figure-3. Note that some plants may be landed on by more than one frog during the night. Of course, you can not see the lines showing the paths of the frogs or any of their hops outside of your paddy ?for the situation in Figure-3, what you can see is shown in Figure-4:
这里写图片描述

From Figure-4, you can reconstruct all the possible paths which the frogs may have followed across your paddy. You are only interested in frogs which have landed on at least 3 of your rice plants in their voyage through the paddy. Such a path is said to be a frog path. In this case, that means that the three paths shown in Figure-3 are frog paths (there are also other possible frog paths). The vertical path down column 1 might have been a frog path with hop length 4 except there are only 2 plants flattened so we are not interested; and the diagonal path including the plants on row 2 col. 3, row 3 col. 4, and row 6 col. 7 has three flat plants but there is no regular hop length which could have spaced the hops in this way while still landing on at least 3 plants, and hence it is not a frog path. Note also that along the line a frog path follows there may be additional flattened plants which do not need to be landed on by that path (see the plant at (2, 6) on the horizontal path across row 2 in Figure-4), and in fact some flattened plants may not be explained by any frog path at all.

Your task is to write a program to determine the maximum number of landings in any single frog path (where the maximum is taken over all possible frog paths). In Figure-4 the answer is 7, obtained from the frog path across row 6.

Input

Your program is to read from standard input. The first line contains two integers R and C, respectively the number of rows and columns in your rice paddy, 1 <= R,C <= 5000. The second line contains the single integer N, the number of flattened rice plants, 3 <= N <= 5000. Each of the remaining N lines contains two integers, the row number (1 <= row number <= R) and the column number (1 <= column number <= C) of a flattened rice plant, separated by one blank. Each flattened plant is only listed once.

Output

Your program is to write to standard output. The output contains one line with a single integer, the number of plants flattened along a frog path which did the most damage if there exists at least one frog path, otherwise, 0.

Sample Input
6 7
14
2 1
6 6
4 2
2 5
2 6
2 7
3 4
6 1
6 2
2 3
6 3
6 4
6 5
6 7

Sample Output
7

Source

IOI 2002

这道题是Coursera上的《算法基础》讲到的一道题,课上刘老师讲的是用枚举方法求解的,由于要考虑的细节比较多,需要尽快排除错误答案(否则会超时)前前后后花了我四天时间,一直卡在细节上通不过,今天终于通过了,下面附上代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int R,C,N;
//选择合适的数据结构 
struct PLANT
{
    int x,y;
};
PLANT plants[5001];
PLANT plant;
bool operator <(const PLANT &a,const PLANT &b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}


int main()
{
    int dx,dy,px,py;
    int max=2;
    scanf("%d %d %d",&R,&C,&N);
    //数据输入
    for(int i=0;i<N;i++) 
        scanf("%d%d",&plants[i].x,&plants[i].y);
    //排序
     sort(plants,plants+N);//整理用法 
    //枚举路径
    for(int i=0;i<N;i++)
    for(int j=i+1;j<N;j++)
    {
        dx=plants[j].x-plants[i].x;
        dy=plants[j].y-plants[i].y;
        px=plants[i].x-dx;
        py=plants[i].y-dy;
        if (px >= 1 && px <= R && py >= 1 && py<= C )
            continue;
        //第一点的前一点在稻田里,
        //说明本次选的第二点导致的x方向步长不合理(太小)
        // 取下一个点作为第二点
        if (plants[ i ].x + (max - 1) * dx > R)
            break;
        //x方向过早越界了. 说明本次选的第二点不成立
        //如果换下一个点作为第二点, x方向步长只会更大, 更不成立, 所以应该
        //认为本次选的第一点必然是不成立的, 那么取下一个点作为第一点再试

        py = plants[ i ].y + (max - 1) * dy;
        if ( py > C || py < 1)
            continue; 
        //y方向过早越界了, 应换一个点作为第二点再试

        int count=2;//注意初值 
        PLANT plant;
        plant.x=plants[j].x+dx;
        plant.y=plants[j].y+dy;
        while((plant.x<=R)&&(plant.x>=1)&&(plant.y>=1)&&(plant.y<=C))
        {
            if(!binary_search(plants,plants+N,plant))
            {
                count=0;
                break;
            }
            count++;
            plant.x+=dx;
            plant.y+=dy;    
        }
        if(max<count)
            max=count;
    } 
    if(max==2)
        max=0;
    cout<<max<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值