HDU1163 Eddy's digital Roots

1163
Eddy’s digital Roots
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6896 Accepted Submission(s): 3776

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy’s easy problem is that : give you the n,want you to find the n^n’s digital Roots.

Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

Output
Output n^n’s digital root on a separate line of the output.

Sample Input
2
4
0

Sample Output
4
4

Author
eddy

Recommend
JGShining | We have carefully selected several similar problems for you: 1164 1194 1196 1170 1141


和1013一样,只是输入的数据不同,都是九余数定理的做法;本题需处理的是由于将n^n拆分开:取n的树根a乘以n,再取a*n的树根b即为n^2的树根,那么n^n的树根只需要不断的取树根与n相乘,循环n次就好。
例如5,5*5=25,树根为7;7*5=35,树根为8,5^3=125,树根为8;8*5=40,树根为4,5^4=625,树根为4;4*5=20,树根为2,5^5=3125,树根为2;

#include <stdio.h>
int main()
{
    int n, a, sum, i;
    while (scanf("%d", &n) && n)
    {
        sum = 1;
        for (i = 0; i<n; i++)
        {
            sum = sum*n % 9;
        }
        if (sum == 0)
            printf("9\n");
        else
            printf("%d\n", sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值