HDU1405 The Last Practice

1405

The Last Practice

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11018 Accepted Submission(s): 2495

Problem Description

Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input
Input file contains multiple test case, each case consists of a positive integer n(1

#include<stdio.h>
#include<vector>
using namespace std;
int isPrime(int n)
{
    int i;
    for (i = 2; i*i <= n; i++)
        if (n%i == 0)
            return false;
    return true;
}
int main()
{
    bool flag = false;
    vector<int>Prime;
    vector<int>::iterator Iter;
    int n, i, count,cns=1;
    for (i = 2; i <= 65536; i++)
    {
        if (isPrime(i))
            Prime.push_back(i);
    }
    while (scanf("%d", &n)&&(n>=0)) 
    {
        if(flag)printf("\n");
        flag = true;
        printf("Case %d.\n", cns++);
        for (Iter = Prime.begin(); Iter != Prime.end(); Iter++)
        {
            count = 0;
            while (n%(*Iter)==0)
            {
                count++;
                n /= *Iter;
            }
            if(count)
            printf("%d %d ", *Iter, count);
            if (n < 2)
            {
                printf("\n");
                break;
            }           
        }       
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值