1031 Hello World for U (20point(s))

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

 

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

 

Sample Output:

h   !
e   d
l   l
lowor

 思路:

n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

仔细研究这个算式,这里的k是不大于n2的,也就是说n1和n3是不大于n2且满足n1+n2+n3=N+2的最大值。那么自然有n1=n3=(N+2)/3,n2=N+2-(n1+n3)。

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char** argv) {
	string s;
	int n1, n2, n3;
	while(cin >> s){
		int len = s.length();
		n1 = (len + 2) / 3;
		n3 = n1;
		n2 = len + 2 - n1 - n3;
		char a[n1][n2], pos = 0;
		for(int i = 0; i < n1; i++){//存n1那一列 
			a[i][0] = s[pos++];
		}
		for(int i = 1; i < n2 - 1; i++){//存n2那一行 
			a[n1 - 1][i] = s[pos++];
		}
		for(int i = n3 - 1; i >= 0; i--){
			a[i][n2 - 1] = s[pos++];
		}
		for(int i = 0; i < n3 - 1; i++){//打印除最后一行部分 
			for(int j = 0; j < n2; j++){
				if(j == 0 || j == n2 - 1){
					cout << a[i][j];
				}else{
					cout << " ";
				}
			}
			cout << endl;
		}
		for(int i = 0; i < n2; i++){//打印最后一行 
			cout << a[n3 - 1][i];
		}
		cout << endl;
	} 
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值