A Rational Sequence (Take 3)

欢迎访问https://blog.csdn.net/lxt_Lucia~~

宇宙第一小仙女\(^o^)/~~萌量爆表求带飞=≡Σ((( つ^o^)つ~ dalao们点个关注呗~~

 

一、问题:

Description

An infinite full binary tree labeled by positive rational numbers is defined by:

• The label of the root is 1/1.

• The left child of label p/q is p/(p+q).

• The right child of label p/q is (p+q)/q.

The top of the tree is shown in the following figure: A rational sequence is defined by doing a level order (breadth first) traversal of the tree (indicated by the light dashed line). So that:

F(1) = 1/1, F(2) = 1/2, F(3) = 2/1, F(4) = 1/3, F(5) = 3/2, F(6) = 2/3, . . .

Write a program to compute the n-th element of the sequence, F(n). Does this problem sound familiar? Well it should! We had variations of this problem at the 2014 and 2015 Greater NY Regionals.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set should be processed identically and independently. Each data set consists of a single line of input. It contains the data set number, K, and the index, N, of the sequence element to compute (1 ≤ N ≤ 2147483647).

Output

For each data set there is a single line of output. It contains the data set number, K, followed by a single space which is then followed by the numerator of the fraction, followed immediately by a forward slash (‘/’) followed immediately by the denominator of the fraction. Inputs will be chosen so neither the numerator nor the denominator will overflow an 32-bit unsigned integer. 

Sample Input

4

1 1

2 4

3 11

4 1431655765

Sample Output

1 1/1

2 1/3

3 5/2

4 2178309/1346269

 

二、题意:

第一行数字 T 代表测试样例个数。

接下来的 T 行每行第一个数 cnt 表示序号,第二个数代表n 求第n个结点的值 ( 如图所示,图片不好看凑合着看8~ ) 。

求:第 n 个结点的值为多少。

 

三、思路:

不论第几个,咱们都可以找到它的前一个,对于第n个,它都是来源于第n/2个,然后不断向前找,最终都会找到1/1,然后再倒着推回去推到当前即可。a数组中存的是它的单向路径,比如我们找第7个,它沿途就还会找到第3、第1个。然后,第奇数个都是左面的大于右面,第偶数个都是左面小于右面,按正常顺序推回来即可。

 

四、代码:

#include <map>
#include <set>
#include <cmath>
#include <deque>
#include <queue>
#include <stack>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define eps 1e-10
#define mod 1e9+7
#define PI acos(-1)
#define INF 0x3f3f3f3f
#define lowbit(x) (x&(-x))
#define read(x) scanf("%d",&x)
#define mem(a,b) memset(a,0,sizeof(a))
#define fori(a,b) for(int i=a;i<=b;i++)
#define forj(a,b) for(int j=a;j<=b;j++)
#define fork(a,b) for(int k=a;k<=b;k++)
#define ifor(a,b) for(int i=a;i>=b;i--)
#define jfor(a,b) for(int j=a;j>=b;j--)
#define kfor(a,b) for(int k=a;k>=b;k--)
#define IN freopen("in.txt","r",stdin)
#define OUT freopen("out.txt","w",stdout)

using namespace std;
typedef long long LL;

int main()
{
    int T,cnt,n;
    read(T);
    while(T--)
    {
        scanf("%d %d",&cnt,&n);
        int x=n,k=0,p=1,q=1,a[100000];
        mem(a,0);
        a[0]=x;
        while(x)
        {
            a[++k]=x/2;
            x/=2;
        }
        ifor(k-2,0)
        {
            if(a[i]%2==0)
                q+=p;
            else
                p+=q;
        }
        printf("%d %d/%d\n",cnt,p,q);
    }
    return 0;
}

 

欢迎访问https://blog.csdn.net/lxt_Lucia~~

宇宙第一小仙女\(^o^)/~~萌量爆表求带飞=≡Σ((( つ^o^)つ~ dalao们点个关注呗~~

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值