HDU 4989 Summary BestCoder Round #8 解题报告



Summary

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 328    Accepted Submission(s): 201


Problem Description
Small W is playing a summary game. Firstly, He takes N numbers. Secondly he takes out every pair of them and add this two numbers, thus he can get N*(N - 1)/2 new numbers. Thirdly he deletes the repeated number of the new numbers. Finally he gets the sum of the left numbers. Now small W want you to tell him what is the final sum.
 

Input
Multi test cases, every case occupies two lines, the first line contain n, then second line contain n numbers a 1, a 2, ……a n separated by exact one space. Process to the end of file.
[Technical Specification]
2 <= n <= 100
-1000000000 <= a i <= 1000000000
 

Output
For each case, output the final sum.
 

Sample Input
  
  
4 1 2 3 4 2 5 5
 

Sample Output
  
  
25 10
Hint
Firstly small W takes any pair of 1 2 3 4 and add them, he will get 3 4 5 5 6 7. Then he deletes the repeated numbers, he will get 3 4 5 6 7, Finally he gets the sum=3+4+5+6+7=25.
/*一开始的想法就比较简单暴力,先模拟,再考虑到100个数据会产生 100*(99)/2个数,如果要去找的话
  直接全部找完的话就可能需要将近一亿次,于是想到排序加二分,结果发现直接快排,然后简单if(b[i]!=b[i-1]) sum+=b[i];//前后不相等就可以求和,这样一来省去了二分!*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int a[110],b[11000],cnt; 
int cmp(const void* c,const void* d)
{
	int *a,*b;
	a=(int *)c,b=(int *)d;
	if(*a>*b) return 1;
	else return -1;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{	memset(b,0,sizeof(b));
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		cnt=0;long long int sum=0;
		for(int i=0;i<n;i++)
		{
			for(int j=i+1;j<n;j++)
			{
					b[cnt++]=a[i]+a[j];
			}
		}
		qsort(b,cnt,sizeof(int),cmp);
		sum+=b[0];
		for(int i=1;i<cnt;i++)  
		if(b[i]!=b[i-1]) sum+=b[i];  
       printf("%I64d\n",sum);  
	}
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值