hdu 1051 贪心

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12148    Accepted Submission(s): 5033


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

Source
Asia 2001, Taejon (South Korea)
每个stick有两个 数值 l和w,若b.l>=a.l&&b.w>=a.w 则 a,b可以构成一个链a->b 依次类推,
现在其实就是要找到 给出的n个stick中,找出最少的链,帮他们全部遍历完!
这样 就好像图论里面的偏序关系,所以先进行排序,对l或者w排序都是一样,只是固定一个顺序,然后对
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string>
#define maxn 5020
using namespace std;
typedef struct stick{
	int l,w;
}stick;
stick num[maxn],dp[maxn];
bool cmp(stick a,stick b)
{
	if(a.l>b.l)
	return false;
	else
	if(a.l==b.l&&a.w>b.w)
	{
		return false;
	}
	else
	return true;
}
bool check(stick a,stick b)
{
	if(b.l>=a.l&&b.w>=a.w)
	return true;
	else
	return false;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n;
		cin>>n;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&num[i].l,&num[i].w);	
		}
		sort(num,num+n,cmp);
		int cnt=1;
		memset(dp,sizeof(dp),0);
		dp[cnt]=num[0];
		for(int i=1;i<n;i++)
		{	int ok=0;
			for(int j=1;j<=cnt;j++) 
			{
			if(check(dp[j],num[i]))
			{
					dp[j]=num[i];
					ok=1;
					break;
			}
			}
			if(!ok)
			{
				dp[++cnt]=num[i];  // dp数组是用来储存当前的所有链的末端的stick
			}
		}
		cout<<cnt<<endl;
	}
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值